Integrated vs dedicated AMD gpu issue

Hi i have a laptop with an AMD A10-9620P apu and a dedicated AMD Radeon RX 540…lately i could use the dedicated gpu with the latest amd drivers (before it wasn’t prompted)but if i run a simple program with a blank loop i get 400 fps more with the apu (using the lunarg fps counter on the window),i’m using the first queue of these 2 cards in each one of them graphic and present have the same index,and im using the same program (no memory allocations) …is this behaviour normal or is it just a driver bug?

Benchmarking a program that does nothing is not a useful measure of the ability of hardware to do meaningful work.

Also, “400fps more” is a meaningless number. The time difference between 60fps and 460fps is 14.4ms, while the time difference between 460 and 860fps is 1.0ms. One of these is a lot more meaningful than the other.

Don’t measure FPS; measure time.

160 fps dedicated 560 fps integrated at 1200 600 resolution,tried with some primitive too now but didnt change anything,also not measuring time,the gap is visibly huge,maybe i’m doing something wrong,but everything seem ok,