I still couldn't get to work my TNT2 with OpenGL in HALF-LIFE

F.U.C.K…what is going on to my system??? I’ve tried everything from upgrading drivers, tweaking WIN.ini, using NVMax to reinstalling my OS. Still nothing works with OpenGL. Half-life has a minimal requirements in hardware specs and I guess mine has lot more than that. Can anybody tell me what is wrong? DAMN! in fairness with Thelv, I got a lot of suggestions from you man!

I have :

AMD K6-2 500
MVP3 mobo (VIA Chipset)
Vigor Nvidia TNT2 PRO 32MB
Xwave 512 Sound

Can anybody help?


I have been in your situation.

Try this. Isnt the right solution but you will get your openGL games working.


Thanks again…I’ll try it. There’s one more question I wanna ask, If the chipset of the Video card is damage would it work? How 'bout the RAM? Well, probably if it’s damaged it wouldn’t work at all huh? Thanks Again!


I dont know if I got you right.
Does your Direct 3D work?
If it works proper your card is healthy.
Does your Half-Life work in Direct3D mode?
I have always played Half-Life in direct3D
In the new Half-Life product “gunman chronicles” I got better graphic in Direct3D
instead of openGL.
But some games only work in openGL such Quake engine (alice, star trek), soldier of fortune, MDK2 and more.
Have you tested other OpenGL games to see
if it isnt just Half-Life thats fails?

Remember to do a complete uninstall of the old display drivers before you do a new install. Theres a lot of Inf. files that can messed it up again. You cant uninstall the display drivers in normal mode. You have to do it in safe mode or change to VGA-display in display properties and then uninstall(real important).
You said it stopped work after you install the new detonators. The problem should be there.

It really should work for you.

I had the same problem with my sys.
I have a K6-2 and a mobo with the Via chipset and I have noticed a lot of us with that combo have or had theOpengl problem( but with different nvidia vidcards).

I said had because I fixed mine. I don’t have that “DVA=0” line in my win.ini …so my solution turned out to be re-installing the latest via chipset update and NOT enabling the AGP TURBO mode but selecting the normal setting. This forces the system to AGP 1x! Stupid isn’t it? You actually have to slow down your mobo! I also went into the bios and turned my 2x AGP mode there as well.

Halflife, FAKK2, Elite Force and Q3 work just fine now!

Check it out.


I already have a solution, but I did uninstall the old drivers first then install the drivers that came with the card. I used NVmax, a utility that tweak your Nvidia cards. It works with me. Try it. Thanks Thelv, ma’ man!


Cu in counterstrike.