I know, you've probably heard it before - could not load OpenGL subsystem

Basically whenever I try to play any games which need OpenGL, I end up with the console telling me the line the most of you have probably seen before “GLW_StartOpenGL() - could not load OpenGL subsystem” This happens when I try to play Quake 3 Arena, Star Trek Voyager : Elite Forces, and also Star Wars Jedi Knight 2 : Jedi Outcast. I have Windows 98 first edition, NVIDIA RIVA TNT2 Model 64/ Model 64 Pro, AMD Athlon 600Mhz, 64MB Memory.
I tired what it said in the troubleshooting guide for Jedi Outcast, checked my graphics card was compatible, it is, I downloaded the latest drivers, still no help, I asked a friend and he said reinstall the drivers for the graphics card, I tried that and still to no avail. I hope you guys have anything which may help me, but at the moment, all I can think of is formatting the hard drive and trying again.
Also below is the whole console I receive when I try to load up the game, if it helps anyone who can understand all of that.

JK2: v1.03 win-x86 May 3 2002
Initialising zone memory …
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

14974 files in pk3 files
execing default.cfg
couldn’t exec jk2config.cfg
couldn’t exec autoexec.cfg
…detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.

----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
— Common Initialization Complete —
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 16
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

Thanks in advance

man i got the same problem with the open gl subsytem thingy…i have a tnt2 and a p4 and im runnin windows XP…


yeah man im on a p3 800 runnin a tnt 2 card on xp and i got the same stuff, but only since i wiped my drive, it worked fine when i was runnin ME WE NEED HELP

I have the same prob too but on w2k with the same vid card… I cant play any games that require openGL… in XP the games run fine…

I have eliminated out vidcard drivers because those worked B4… DirectX is 8.1…
please help

man i have the exact problem but i might figure it out if i can just have someone tell me where the files go?? cuz i have SOFII multi test and i neeed OPENGL bad!!!

are you guys going to www.nvidia.com and downloading the detonator drivers?

if not - do so

I have the some thing on Star wars Jedi Knight 2


Email me if you find out…

[This message has been edited by PDBJesusFreak (edited 06-18-2002).]

I’ve tried the latest detonator drivers already, still no good.

Ive done everthing they say and I still have problems…

heck… I have a recommened Card… With chip set… same driver and driver version they use and im still getting the same error… Ive gone to there webpage looked at all the help… even submetted to Yoda 4 times already and 24 hours later still no reply… Ill help if they replay but doesnt look like they even know whats going on…

K same problem…hey vo…ok you said it worked on XP right? Well i’m using XP Pro and it’s still says the subsystem is not able to initiate…i’m wondering if my drives are updated but i’m new to this and i really dunno how to find out…

I used to be able to play jedi outcast in win 98. I did a fresh install of xp pro and bam- the typical open gl error message you all mentioned. I also get the error in soldier of fortune 2. I think we will find in the future that a patch will be developed to fix this problem. Either a game patch or a driver upgrade that will correct it. Too many people are experiencing this problem for it to be a minor issue. I have a dell system with the latest nvidia drivers and have tried doing everything possible and still no dice. These game mfg’s need to get their act together. These are name brand vid cards we’re dealing with here, not foreign knock offs. If they can’t design a game to run on a generic system with top name components then these games should cost ten bucks not fifty. These Rip off game companies suck!

But you see the thing is, I haven’t changed anything, my games were working absolutley fine, but this happened a couple of months ago, I must have done something, maybe deleted something by accident, that’s why I am thinking of formatting my hard drive, and trying to reinstall all the drivers and games, but I don’t wanna do that if there is something much easier to do which will solve the problem. All I ever see is a lot of problems, but no one able to ever deliver answers, I think everyone can see that in this post…

thats it i m so fuc… angry on all that bunch of stupid nVIDIA people and OpenGL people they have produed a software that isn t working with hardware they are ohhhh gggg **** it all i ve got 3 games MOHAA, SOF2 and Q3 and all of them are not!!! working on this **** !!! and even if i want to solve this problem i couldn t because i couldn t even contact them it is **** and i don t want to talk about it !!!

desperadoooo ;]

OK guys just thought id pop in with a Note or to
I have a duel Boot PC
98SE and 2000 pro
Now in 98 everything works fine but in 2k pro i have that error.
Ive noticed it that this problem seems to happen with the TNT 2 cards
I am looking for away around this at the moment if anyone has it please feel free to email me if not email me to see if i have found a way that way i can keep intouch with those that are eager

It seems everyone is having this problem, me to! so why dosen’t any one from OPENGL answer our question? I have Windows XP with a g-force 2, and Medal of Honor AA and Star Wars Jedi Knight 2 doesn’t work!!!

yes me as well but its funny i used to play quake 3 no problems ,but since this started up i have not tried it something is screwed somewhere what is all this pixel format rubbish

i have winME (the worst of them alll i know)
with a ATI Radeon 7500 i sued to have mohaa quake III and counter-strike installed and like some of you guys soemthing happened awhile ago when all my games stopped working cause of opengl (i could have done something but i dont think so) i was actauly playing counter-strike in the 3d mode. does anyone know a good link to d/l opengl??? all the freakin game companys tell me glsetup.com but where at glsetup.com!!! and where is opengl admin people this is a place for help so help us!!!

i have a trident/opengl video card and run windows 2000 on a laptop and have the same error generated when I downloaded mohaa

ok I know now the solution. There are two different kind of reasons that are cousing this problem:

  1. You’ve got Windows XP or 2k this is the problem of Microsoft programmers so we have to wait till they ll fix up and will make a patch to it. So to get out of this sh*t you have to install a secound OS (for example Windows 98) and, like I did, play the game on it.
  2. You have to remove the line DVA=0 from your win.ini file in WINDOWS folder by putting at the beginning “;” so it will be something like this: ;DVA=0 .

Ohh it can be something else but I ve found this two solutions. Mail me if you have any probs with this on brox@poczta.fm

Thanks br0x. Finally my games worked, that line “;DVA=0”, thanks for your help. I really do appreciate it.

[This message has been edited by gigabz666 (edited 07-08-2002).]