I can't play games like Medal of Honor & Sim City 4

When I try to run medal of honor the computer shows me the next error:

“GLW_StartOpenGL() - could not load OpenGL subsystem”

It was really hard to get this game and now that I’ve finally got it I can’t play it, and when I try to open Sim City 4 it just doesn’t start and I think it’s the same problem.

I have the same problem with Medal Of Honour. Error is :
“Initializing OpenGL driver
GLimp_Init()- OPENGL Vendor string is NULL”
I have AMD 1800,480MB DDR, GeForce2 32Mb. pls, help me.

ive got exactly the same problem as paulj someone help, please

igot exactly the same problem please HELP

Same problem on MOHAA:
“GLimp_Init()- OPENGL Vendor string is NULL”
Have a GeForce4 Ti 4200 on WinXP running 44.03 drivers.

…something about being unable to select a PFD.

Running a bit of “debugging” on the problem, only confuses me further:

  1. If I “roll up my own” app. using OpenGL ,say, glut, OpenGL runs fine. Maybe I’m linking diferent libs?

  2. It’s not just MOHAA that crashes. All games that use OpenGL refuse to start.

3.Rolled back to 41.09 drivers. Same result.

  1. The big one, is that I CAN START MOHAA provided I click on the link the very second my desktop appears after rebooting the computer.(you know, while the microsoft sound still plays)So I’m thinking maybe it’s a memory problem (unlikely, I have 2GB RAM), or some process running in the backround “locks” the OpenGL?is this even possible, I’m a bit new to OpenGL?if yes, is there any way I can get a PID on the processes using OpenGL resources?

I tried to simulate that “GLW_StartOpenGL() - could not load OpenGL subsystem” error. I removed opengl32.dll from my system32 folder and i got the error. when i put it back that message never showed up again.

The problem I have with mohha is that when i go to load a level it crashes at the loading bar. Still havnt fixed. And beleive me Ive tried everything.