how to disable lighting on for multitextuing

Originally posted by bw359:
ARG!!! Does anyone know out there how to by-pass lighting calculated by OpenGL using multitexturing!? We just want to enable “full bright” texels in a single pass while using the OpenGL lights.

You can’t.

The easiest thing is to use the texture environment (p155 of spec). First stage would be add with arg0 and arg1 set to primary_colour and texture0. This would give you your glowing model. 2nd stage would be set to modulate with arg0 set to previous and arg1 set to texture1. This would give you your lit textured model.

All you have to do to “disable” lighting is to not use the primary_colour as either argument

Note: even if you don’t use the texture you must have a valid texture bound to that stage and have texturing enabled. Just create a nice 1x1 dummy texture.

For more info look into the GL_ARB_texture_env_combine extension. It has been part of OpenGL since 1.3. Old drivers will usually support OpenGL 1.2+GL_ARB_texture_env_combine.