How I fixed "Could not load OpenGL subsystem"


If you are the least bit wary about fooling with your system settings, look towards the bottom of this post for a section called “A POSSIBLY SAFER THING TO TRY FIRST” and do that instead. I make no guarantees about any of this, but I’m just happy to be playing Quake-based games again. This worked for me, but I’ve only had it going for about 2 hours now. - Tritone

Like others on this forum, I’ve got an nVidia GeForce-based card and have been having trouble for months getting Quake-based games to run. Sometimes they’ll hang on a blackscreen. Or like SOF II, they just complain they “could not load OpenGL subsystem” and exit.

I have a brand new nVidia GeForce 4 Ti4400 and Win98SE. It was too unbelievable that a brand new video card should have so much trouble running any new game. So I found this forum and stumbled across the suggestion to edit (of all things) C:\WINDOWS\WIN.INI to comment out DVA=0 by putting a ; in front of it, so it looks like this:


Well, this ALMOST worked. SOF II would now come up, and change resolutions, and change the cursor to an I-beam, and then… hang. DOH. No luck. But so close! But that gave me an idea…

While looking around in WIN.INI, I was amazed at how much OLD CRAP was left in there. I’m quite sure this machine was originally Win95, then Win98, then Win98SE, and I actually found references to EIGHT previously-installed video cards in my Registry and WIN.INI! Who knows what some of those settings were doing to my computer.

So, what did I do? I renamed WIN.INI to WIN_BAK.INI, and rebooted the computer. I like to live dangerously. I figure… if the machine crashed, I could either rename it back, or I’d have to reinstall Win98SE all over again… a step I figured was inevitible anyway.

Guess what? Nothing happened! No crashes, no blue screens, not even a complaint! It just booted up like nothing was unusual. I took a look in the C:\WINDOWS folder, and sure enough, Windows had rebuilt me a new WIN.INI file, but it only had about 10 lines in it! Is there any software out there that really uses WIN.INI much anymore… I read somewhere (perhaps incorrectly, and if so I’m sure we’ll read about it that it’s mostly for legacy programs that never heard of the Registry, or need to interact with other old programs that use WIN.INI. Everything uses the Registry these days. HOWEVER, Windows DOES PROCESS the WIN.INI file settings, and (obviously) they can NEGATIVELY IMPACT your system if some crappy old video card from 5 years ago put a setting in there that says “this computer has no video accelerator”. (I’m just guessing that’s what DVA=0 might have meant).

But the bottom line is… I CAN PLAY SOF II! It came up with nary a hitch, and I played the entire Tutorial without stopping. Woo hoo!

By the way, here’s another tip I found that SOMETIMES worked for me in the past (especially with MOH and JK). Sometimes if the wind was blowing just right, I COULD get those game to run. I found that if I could switch the game to WINDOWED MODE [by pressing Alt-Enter on the keyboard]… so that it plays inside a windowframe ON your desktop, without taking over the fullscreen, I could play the entire game with no problem at all! I played both MOH and JK in windowed-mode like that. I wasn’t HAPPY about it, but hey. I suspect there may be a Quake config setting (for those who know such things… I don’t) you could put in your Quake-based games that would FORCE it to come up windowed, and maybe YOU can run them this way if you can’t get any of the aforementioned solutions to work. Hopefully someone will post that solution here (if it exists).


If I get really ambitious, I may try to reinsert some of my old WIN.INI settings back into the new (short) WIN.INI to see at what point SOF II fails again. For the record, I found DVA=0 in a section called:


There were about 10 other lines in this same section… maybe if I had just commented them ALL (by putting ; in front of each one), I wouldn’t need to remove WIN.INI completely. You MIGHT want to try this first.

Anyway, if I have any trouble with my system, I’ll be sure to post it here. If you don’t hear from me, assume I’m playing SOF II!!


It’s been a few days since I did the “rename WIN.INI” trick, and although I’ve had zero problems with openGl games, there have been a few consequences that were easily remedied. For example, my printer wouldn’t respond. To get everything working again, I restored (from my original WIN.INI) almost everything that didn’t look "graphics related. By far the SAFEST approach is the second approach above, to simply remove (or comment out) sections that particularly look suspicious. In my original WIN.INI there were sections that were obvious choices for experimentation/removal, namely:


Always keep a backup of your original WIN.INI in case you need to recover everything. The best way to “comment out” a section is to rename it, like this:


Then you don’t have to put semicolons in front of each line of that section.

Sections to AVOID are these:


You get the idea. Good luck!

I just did what you suggested. I renamed the win.ini file then deleted the original. I shutdown my computer and then rebooted. It worked perfectly. The win.ini file before was very long. The new one created by windows is about 10 lines long. Everything works great and Medal of Honor functions with no faults or errors. I have kept the renamed copy of the original win.ini just in case but have not found anything yet that has been adversely affected. Thanks.

I found a file that is named “win”. The properties say that the ms dos name is win.ini. Is that the one I rename, and if so do I just right click and rename it?


I have had OpenGL issues, well a lack thereof, for over a year on my TNT2 Ultra card.

Commented the line in win.ini and VOILA!


BTW - The person that asked about win being win.ini… I would suggest you tell windows to show ALL file extentions. (Windows hides ‘known’ extentions by default.)

In 95/98: Click…Start…Settings Folder Options.
Click the view tab and find the checkbox for “Hide File Extentions of known types” and make sure it is UNCHECKED.
Look for your win.ini in your windows directory. You should now see if the file you are asking abouty actually IS your win.ini.
You could also do a Find File win.ini to locate.
Hope that helps ya.
And, Once again, THANK YOU!!!

(I suspect that a NVidia driver update placed this setting or set it to 0… my 2 cents)


Oh yeah…
1 other ‘help’…

The Windowed thing…

You ca TRY adding a -win or /win to the end of your ‘shortcuts’ or command lines. Some games may even require a /window or -window.
(Technically either a - OR / should work)

Games that I know of that will run ‘windowed’ using the above switches:
Half-Life (and all mods) (-win)
BattleZone (/win)
Diablo II (-win)

Not a very extensive list… but you can always try others.

Tritone - THANKS AGAIN!!!

Just woundering does it matter what windos u have i have windos ME. Do u think it will work for it to.

No…on ME, It should not matter… and it should work.
I do suggest the LATTER method.
That is…
COMMENT out (with a the DVA line in your win.ini.
The only versions that this may not apply to are Windows NT, XP, and 2000.
I may look at this on those OS if anyone would ask…
Otherwise, ME is based on the same ‘track’ as all of the previous home versions.
If you decide to do the ‘delete’ trick, BACKUP BACKUP BACKUP!!!
or simply rename to something like
That way, in safe mode or DOS, you can rename it back to win.ini (after renaming the ‘new’ one to something like

If this refers to the /win (to run in a window) advice, that too, should work on ALL windows systems (Including NT and 2000 and XP)
Hope that helps.


The line above that show the should read…
(With a ; )

i tried your method of deleting WIN.INI & then restarting my computer but when i went to run my game the thing still said “could not load opengl subsystem” so im really pissed off do you think there might be a reason for this ???

What is your config?
OS, Hardware, Vid Card, etc.
Also - Which drivers are you using on the Vid Card?

Umm jsut refering to teh thingy above, whatt do i rename and what rename it to…?

Alright…I have no DVA=0 in my win.ini.

Im running XP and my ****ty video card is a S3 Gaphics Inc. Savage4. Phirax drivers dont work, tweaked drivers dont work, SciTech GlDirect 3.0 doesn’t work, S3Tweak doesn’t work. Anyone have a suggestion. I get that OpenGL subsystem error on RTCW, SOF2, plus I can’t play ANY game with OpenGL. Counter-Strike doesn’t recognize OpenGL on my video card, Unreal Tournament 2003 demo crashes after 10 seconds of playing. Renegade looks like plaid! Anyone, should I just buy a new card?

Alright, to anyone who can help me out here… I run on the xp pro os and i have a geforce4 mx420 and not a single game i have will run that requires opengl support. I have the newest driver for the vid card and I’m confused… HELP!