Help: Soldier of Fortune Error

Every time i try and open Soldier of Fortune: Platinum, i get the following error:

"Could not initialize OpenGL rendering environment!

Make sure you have the latest drivers installed(GLsetup is reccomended)
Make sure your desktop has more than 256 colors"

I have the desktop on 32 bit, and i dont know what the other part means.

My OS is Windows 98SE, and my graphics card is an NVIDIA RIVA TNT2 Model 64 Pro.

Please help.

Make sure the demo of the game is uninstalled and the folder is deleted.

Make sure you have one of the supported video chipsets listed in the minimum system requirements.

Make sure you have the latest video and sound card drivers from the manufacturers’ websites.

Set your desktop settings to 640 by 480 and High Color (16 bit).

Make sure the 3D hardware acceleration is turned all the way up.

  1. Right-click on the My Computer icon on the desktop and select Properties.
  2. Select the Performance tab and click the Graphics button.
  3. Make sure the acceleration slider is set to Full.

For Windows XP and 2000:

  1. Click on the Start button > Settings > Control Panel.
  2. Double-click the Display icon.
  3. Click the Settings tab.
  4. Click the Advanced button.
  5. Click the Troubleshoot tab.
  6. Make sure the acceleration slider is set to Full.

If after trying the above solutions the game still does not work, check the following:

  1. Click the Start button > Run and in the run box type “Sysedit” without the quotes and click the OK button.
  2. When Sysedit comes up you should see a bunch of cascaded windows, select the window that says Win.ini above it.
  3. The Win.ini window should come to the foreground, scroll through the list of items until you come to [DrawDib].
  4. Look for a line under [DrawDib] that says DVA=0 and remove it.
  5. Click File, then Save and close the Sysedit program.
  6. Try the game at this point.

If you do not see the DVA=0 line under the [DrawDib] section, then this is not the cause of your problem. DVA stands for Direct Video Access, and is commonly set to 0 to fix issues with older games or video problems with old software. Unfortunately it causes the game to not recognize OpenGL support on your system as well. The only way to fix this is to remove that line. This should not affect anything on your system.

Hum… from Activision Support… you know, the makers of the game.

[Activision Support]( &p_search_type=search_nl&p_sort_by=dflt)