GraphicPlugin error when launch Hello_xr example


#1

Hello,

When I execute hello_xr exe from open_xr project, I have the error “Graphics Plugin parameter is required”. I don’t know how to fix it.

Regards,


#2

Your topic is about OpenXR, so I’ve taken the liberty of moving it to the OpenXR category. Plesae post what you have tried to fix this, any code where you think it might be causing the issue, along with any system details you think might be helpful, you will get a faster response. The more details you supply, the folks on these community forums will be able to help.


#3

Hi,

Thank you for moving it to the right category. I have installed the mixed reality openxr runtime of Microsoft, and build the open xr project.

When I build the hello_xr project I have this informations but I have installed Vulkan SDK :


#4

Hi,

Nobody has the same error ?

Regards,


#5

If you do a websearch, you get a hit for the source code that emits this:

The code suggests that the cause of this error is: no --graphics or -g parameter was provided as a command-line parameter to the program.

From the usage (see ShowHelp() at the top of this same module), you need to provide --graphics or -g followed by one of: D3D10, D3D11, D3D12, OpenGLES, OpenGL, or Vulkan.


#6

Hi,

Thank you for your answer, I understand that but when I build the project with CMake, the generation is a success except the fact that he doesn’t found the VulkanRegistry_DIR.

Do you think that it is the origin of the error ?

Regards,


#7

I just don’t understand where I have to provide this graphic plugin.


#8

On the command-line for hello_xr.exe. For example, from the usage it sounds like this should be acceptable:

hello_xr.exe -g OpenGL

#9

Okay it works, thank you for your help !