Google 3D Warehouse announcement on Wiki Main Page

The Wiki main page, <> lists an announcement with the simple text, “14:17, 22 October 2007 (PDT) Every model on Google 3D warehouse is now available directly in COLLADA format.”

However, the link to the Google 3D warehouse page has no information about Collada.

Where are the Collada versions of the Google 3D warehouse models found?

Was this a snapshot of what was there on Oct 22 or is this conversion being maintained?

Any help would be appreciated.


I am not sure why some models are available in the COLLADA format, and some not

I browsed randomly the warehouse, and found most models seems available in COLLADA - here’s one from example … dc10c1c8e#

Hi Remi,

Thanks for getting back to me. It turns out there are some files that do and some that don’t and some that do, just hidden under another name: Google Earth 4.

It turns out that the KMZ file you get as Google Earth 4 format is actually
a ZIP file. Change the file extension and unZIP it and in the “models” folder is a DAE file, the Collada-format file.

This means that SketchUp itself can be used as a converter to get Collada format files from SketchUp files – just export as Google Earth 4 and then unZIP it.

I hope this helps,


Hopefully someone knows the answer to this as banging my head against the wall is getting painful!

I grabbed the latest version of SketchUp off Google then downloaded the sample geometry sets.

I’ve tried loading several of the objects into SketchUp and then saving as Google Earth 4 .kmz files. In each case I rename the .kmz to .zip and unzip and out pops a directory with a .dae in it and another directory with the textures.

The problem is, I can’t get these files to load into any other Collada application and I can’t figure out what is going wrong.

According to the stand alone coherency test application there is nothing wrong with the .dae file so it’s Collada compliant.

After running the .dae through refinery (running both bindmaterial fixer and kmzcleanup) coherency test still doesn’t find anything wrong, but the files still won’t load.

FX Composer 2 gives and error as “Instance Node with unknown reference found”

So, either SketchUp is exporting files that are broken or I’m doing something dumb. I suspect the latter! Can anyone help?

Thanks in advance.