Hi all. I am trying out glutGameMode for the first time and have run into a little problem. My program runs great when it is windowed, but if I run it in game mode then it appears that the depth test is not working (i.e. things behind appear in front of things in front) I have tried this on several machines and the same problem arises. I know that I am probably just not setting a flag correctly — any ideas
Thanks in advance

glutgamemode is nothing more than a wrapper
to run your opengl in full screen mode.
I used to use this as well, but you are much
better off getting into the habbit of setting up your window using proper windows
code (for example, any of the NeHe examples).
These allow for fullscreen mode and much more control over the size of the window, if
you want it windowed. Also be aware that when
running in fullscreen mode, depending on wheather or not you have a 3dfx card (in which case you need a differnt openg32.dll for the thing to work properly) , gamemode will not work …

Thank you for your reply, but I want to know how to use glutGameMode effectivly, and I want to change the resolution of the users screen…