gluTessCallback compile error on OSX

I keep getting the following error when trying to compile the following tessellation code in XCode on OS X:

error: initializing argument 3 of ‘void gluTessCallback(GLUtesselator*, GLenum, GLvoid()(…))’
error: invalid conversion from 'GLvoid(
)()’ to ‘GLvoid (*)(…)’

my call back function is declared as follows and I am using the following code to register it:

gluTessCallback(tess, GLU_BEGIN, (GLvoid () (void)) glBegin );
gluTessCallback(tess, GLU_VERTEX, (GLvoid (CALLBACK
) ()) &glVertex3dv );
gluTessCallback(tess, GLU_END, (GLvoid (CALLBACK*) ()) &glEnd );
gluTessCallback(tess, GLU_TESS_COMBINE, (GLvoid (CALLBACK*) ()) &combineCallback );
gluTessCallback(tess, GLU_ERROR, (GLvoid (CALLBACK*) ()) &errorCallback );

#ifndef CALLBACK
#define CALLBACK

static void CALLBACK vertexCallback(GLdouble *vertex)
glVertex3dv((GLdouble *)vertex);

What must the callback and the call to gluTessCallback look like?

first, you should not cross post.
This question is appropriate in the beginner section. Maybe on the Mac specific too, but only post once, thanks.

Sorry, but the info in the link you send did not work I still get error

“Still get error” is not informative.

  • what code you used this time ?
  • what error you got ?
  • at which line ?

If you want to be helped, you seriously need to read and understand this :

Being abusive will not get you the help you need

The link provided works fine for me

Did you compile it in XCode?