glutAttachMenu() broken on Fedora 17

An upgrade from Fedora 16 to Fedora 17 seems to have broken menu attachment or activation. Where as “glutAttachMenu(GLUT_RIGHT_BUTTON)” used to bring up a menu on a right click in the window, now nothing happens. The same is true if the other mouse buttons are set as triggers. This has been tested on a number of different Fedora 17 machines with the same result.

The attached cc shows the problem. Unfortunately I have not tested this particular cc with Fedora 16 as I was not aware of the problem until all machines were upgraded. I have an application using a similar call sequence and this used to work with 16 but now shows the fault with 17.

If this is a glut problem, how do I identify the glut version concerned ?

This is similar to the historic bug below, however the part where setting the left button resulting in all buttons triggering the menu does not apply.

Sorry if this should be reported to Fedora and not OpenGL - I don’t know the accepted reporting etiquette between distribution and packaged application.


Your code does not work for me (menu does not appear),
I tried some basic GLUT menu examples from lighthouse3d, they do not display menus either,
recent version of glut must be broken.

I’m on Arch x86_64,
freeglut 2.8.0
nvidia drivers 302.17

I just downloaded and compiled freeglut 2.6.0, and menus are working fine,
maybe temporary solution is to downgrade freeglut until it gets fixed?

There is bug report on freeglut’s tracker:

and discussion about it on Arch forums:

Thanks for trying that out and providing the links. I’ll drop back to the older version while its being fixed.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.