glut programs hangs the computer

Hi all,

my programs written in c++ using vc++ 6.0 and the glut library keeps crashing.
i have installed the glut32.dll, glut.h, glut32.lib files in the correct locations.
still further i have even tried to compile and install the glut source files.
still no success.

and the funniest part is that the programs that were working fine at college crash on my home pc.


Hello Manesh
Why don;t you post the code here so that we could spot if there is anything wrong with it. If it turns out to be ok then you should do a simple win32 based opengl program. if the problem sill persisits then there is something wrong with your hardware.

Yes, try to make a simple program, displaying a rectangle (glRecti). I was creating a screen saver the other day and when it didn’t find some images I used as textures windows would behave strangelly and I had to reboot (fortunately from windows). So it your code is complicated it might be something else. Also, did you upgrade to the latest driver?

Originally posted by minesh:
Hi all,
and the funniest part is that the programs that were working fine at college crash on my home pc.

I think there maybe is a problem in your “tools/Option/directories” of the development environment in pc at college.

Take the “C:” as example.
Opengl file components are made of “gl.h, glu.h, glut.h, glaux.h(C:\Program Files\Microsoft Visual Studio\VC98\INCLUDE\GL), glu32.lib, gult32.lib, glaux.lib,opengl.lib(C:\Program Files\Microsoft Visual Studio\VC98\LIB), glu.dll, glu32.dll, glut.dll, opengl32.dll(C:\WINDOWS\system32)” should be at proper position in your computer and VC++ should include them properly, which could be set in

If you use “MFC”, please notice the directory “C:\Program Files\Microsoft Visual Studio\VC98\MFC”. it is necessary to include it too.

Wish it could help!


If memory serves (And I’m pretty sure it does) GLUT does not ship with the standard libraries/headers of Visual Studio; you download it separately. What may be happening is that you are linking with an older version of a library or including an older header file, even though you THINK you’ve got the most recent. Perhaps version differences are also causing the different behavior at place A and place B.

The way to check this is to goto your C/C++ Directories options, and make sure that the directories that contain the MOST RECENT VERSION of each type of file (i.e., the /include and /lib directories of GLUT, and the latest GL header file, which is definitely not the one you’ll get with Visual Studio. You can probably overwrite the one that’s there but I just drop it in my SDKs directory along with everything else.