glu32.dll error ONLY in Win 98 NOT in W2K, XP or NT

I have created an OpenGL application and it runs fine on my PC with WinXP installed but when I tried it on a friends with 98 it gave a glu32.dll error.

I have now tried changing the compatibility in WinXP to simulate Win98 and it crashes here aswell.

Does anyone know of anything common that causes this or am I going to have to go through all my code testing bits at a time.

Other OpenGL programs run fine in Win98 mode so I know it is my program.

The info you are giving is too generic. It is not obvious at all that the reason your program crashes is Win98. It could crash for a number of reasons but mainly because of hardware differences between the two PCs. Have you tested it anywhere else?

Anyway, you should try to get the latest drivers for the video card on your friend computer.

ups, I haven’t noticed that you said that in your PC it crashes when you get in win98 mode.

I am not aware of any problems of glu under w98, i programmed withour a problem for years under that os. Maybe it is a wgl function or another window function that goes wrong earlier but the app crashes later. You should get the latest drivers though .

I guess you won’t avoid debugging…

Thanks for replying, I have now figured out the problem, took a bit of debugging but eventually narrowed down the culprit to one line of code:


This was being called by a JPEG texture procedure I had used from a tutorial and for whatever reason wasn’t working in Win98 or even Win98 mode in WinXP.

Not sure whether this was due to something else in my code or whether it would always happen, most likely to be my code as I am a relative beginner to OpenGL

This is most likely due to memory problems, you are most likely corrupting mem some where. Also this is why when you would cause a crash free command. Of course it could be the free command itself that was causing the problem. The reason why it would work on XP, NT, 2000 and not win 95/98 is due to the fact that they manage memory diffrently. Code Guard in Borland Builder Pro version 5+ and a few other tools are excelent at tracking down these problems. I had the same problem about a year ago, and it took me a good week of frustration to figure that one out.