glBitmap doesnt show anything on windows 7

Hi @all,

I am writing a rf-measurement software and using opengl for
graphical analysis.
Everything works fine on a windows XP machine. But under a windows 7 machine, there is one big problem.
Every glBitmap call doesnt show anything on the screen.
All the other calls like glBegin(GL_LINES …etc) are working.
Does anybody know why glBitmap doesnt show anything on windows 7 ?
I am using a QT-interface for an opengl frame in my application.

Have you checked your current raster pos and tried some glGetError calls? It wouldn’t be surprising if there was some different behaviour in some parts of the API (owing to the different driver model) although there shouldn’t be.

thank you mhahain !

I checked the raster position.
I even used fixed values and tried to draw any stuff on the screen via glBitmap(), but nothing.
I didnt tried glGetError jet…

…glGetError returns GL_NO_ERROR after calling glBitmap().
I tried this now on 3 windows 7 desktops and 2 laptops.
Allways the same result, nothing get rendered on the screen!
I allready tried to use the freeglut library to render fonts (witch works via bitmaps), but with the same result:
On XP -> works
On w7 -> nothing

Has nobody ever had a similar problem under windows 7 with opengl ?

I tried now the following on windows 7:

Building a small window with opengl context (with freeglut).
And I draw some stuff via glBitmap on the screen, and it worked :wink:

Now it seems the problem comes form the QT-Opengl interface !
I will keep you uptodate, if I found out something new…

…Now I found one windows 7 PC, that shows glBitmap() calls with the qt-opengl-interface.

Any ideas why the others doesnt ?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.