in my program i have a cube drawn with glutSolidCube(1); and i want to anti-ailias the edges so i enabled gl_polygon_smooth but nothing changed. i played around with it for a bit and when i enabled blending it worked except that there was a white diagonal line accros all 6 faces of my cube
where did they come from???

[This message has been edited by jono_123 (edited 07-16-2002).]

GL_POLYGON_SMOOTH enables polygon antialiasing. That is, antialiasing computations are performed each time you draw a polygon. I don’t recommend you to use this kind of antialiasing. Use full-scene antialiasing instead. Here are some reasons for why you should do that :

  1. full-scene antialiasing is hardware-accelerated on most of the recent hardware. polygon antialiasing is accelerated only on professionnal opengl hardware. What’s more, if you use it on, say, a geforce3, your polygons will be software-rendered, and the frame rate will dramatically drop.

  2. polygon antialiasing is very complicated to use. I’ve had the same problem than you. AFAIK Polygons have to be drawn in a strict back-to-front order (unless you change the glDepthFunc). That’s not practical ! With full-scene antialiasing, you don’t have to worry about that.

I think all the necessary info to get started with full-scene antialiasing is in the extensions registry here on


thanks very much
where can i find out how to do full-scene antialiasing
and where is the extensions registry here on