when i turn on the polygon-smooth hint to GL_NICEST, it seems as if the hardware acceleration gets lost sometimes(not any time ).also all quads look “triangulated”,split up in two parts. i’ve a GeForce 2 card, is that the problem?



for what i know, this hint is not working correctly with GeForce cards (some kind kinda not accelerated, or wierdly as you saw).

I believe the few options are : forget about it and turn FSAA on, or buy a Quadro

Hope i’m not wrong about that !

Quads (and polygons) get split up in almost all implementations of polygon smoothing. If you set up blending properly, this won’t matter.

The proper blending setup uses the SRC_ALPHA_SATURATE mode and is discussed in the redbook. You need to be very, very careful about depth buffering.

This is why polygon smoothing is such an unpopular way of doing antialiasing.