I’m not sure if this is the best place to post this so please let me know if there’s a better place.

I’m have a problem getting the current raster position to work on Solaris. I’m using a library called gl2ps that converts gl code into different printable formats. I’m having a problem with non-vector primitives like text. The libary assumes that user used glRasterPos to place the text. In the example they provide they use glRasterPos to place the text and then glutBitmapCharacter to draw it. When the library needs to write the code to a printable version they do the following. The library changes the glRenderMode to GL_FEEDBACK. The program using the library calls glRasterPos with the same arguments as before and then the library calls glGetFloatv(GL_CURRENT_RASTER_POSITION, pos). And uses the results from this to position the text. However, on Solaris I get garbage back as positions.

I was wondering if anyone had any ideas why. It seem to have something to do the changing the render mode to feedback because if I comment that out the glGetFloatv returns the correct value. The feedback buffer does not over flow. I wrote the authors of the library and they suggest that it might be a bug in my XServer. I was wondering if anyone agreed or had other ideas. I’m trying to get the sys people to update my opengl.

I’m working on Solaris 8 operating system using opengl 1.2.3. There code works fine on different Linux platforms I’ve tried. I haven’t tried it yet on the mac.

Any suggestions you have would be appreciated. If you need more information please let me know. I understand I may have been a bit vague in parts.

Thanks in advance for you help


No pixels are produced by rasterization when in feedback mode. You can use the glPassThrough function to place a marker/token in the feedback buffer.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.