GF4 ti4200 fps problems

i have a not bad pc:
1.2 athalon, 768meg/ram, gf4 ti4200, but i get 30-40fps when playing games such as CS. I have tried many differnt versions of the detonater drivers, set my bios to optimal defaults, but still bad fps. I think it must be the GF4, as i had no probs wiv my GF2 mx. Can any1 help , cheers byron

well firstly, let me burst your bubble there…
Windows does not use any more than 512mb ram (nope, not win98, not winme, not winNT, not win2k and not winXP; longhorn, hopefully will, but then, we also hope it to be a 64bit system so we can use the new amd cpu (althon64) thats coming out soon.)

So if you have 512mb or 768mb or 6gb, it wont make any diference, windows will only use 512mb. You can, however make use of some memory management programs that will be able to make use of the extra ram, but that will cost (and not so little) performance.

Anyway, sounds to me like you require a good old time, clean format. Specially considering that you’ve tried several diferent drivers.
Get the latest official nvidia drivers anyway…
One thing that you should double check before doing anything else is if your motherboard has AGP 4x and that 4x is ENABLED in the bios.

a 4x agp card WILL have lower performance than 2x AGP cards on 2x. Infact, it can have lower performance than pci cards (my old gf2 used to run slower than my even older voodoo banshee when i had it in a 2x agp (yes, it needed 4x)).
After i upgraded the motherboard, then i got the performance I deserved.

Now, when i upgraded to my gf4ti4600, I fully uninstalled the video drivers (before I even took out the gf2) then i put in the gf4, let windows install whatever driver.
then I installed the latest official nvidia drivers and it all worked fine.

So, hehe, little resume:

  1. check agp speed supports and is set to 4x (in motherboard manual, then in the bios)
  2. if you still got problems, install latest nvidia drivers (even if you’ve tried it before)
  3. if you still got problems, uninstall the drivers, remove the card in device manager, restart the pc, let windows install any driver (even if its “standart svga card”); then install the latest nvidia (43.45 i think)
  4. if you still got problems, consider removing ram so that you only (lol, ONLY) have 512
  5. if you STILL got problems, check to see if the gf4ti really is less than 8 times faster than the gf2mx (install gf2mx and check). and if so, contact the card manufacturer and your hardware suplier.