Geforce MX under W2K slow down, need help

Have done some benchmarks with 2 different PC’s.

  1. PC : PII-300, 64 MB Ram, TNT2, Win98 SE
  2. PC : PIII-866, 256 MB Ram, Geforce MX W2K, SP1

I write a little OpenGL test demo with delphi5 (just an rotating triangle, no textures, no ligthing, etc…)
I run it on both PC and to my big suprise the demo runs 5-6 times slower on the P866.

Then i delete all triangle code. Now i have only a loop with the SwapBuffer command and a loop counter.

Again, run it on both PC’s.
Result is the same. P866 slower !!!

Any idea what this could be ???
Need help, please…


Bad drivers? Try the lastest drivers from NVidia .

Maybe you have vsync enabled on one system, and disabled on another? Or the refresh rates don’t match…

Thanks, Bob
at the moment i use driver version 5.12.634
i have forgotten to say, that it is a new Dell PC. What is the current driver version ?
i take a look on nvidia site and download the current release called and try to install it, but install procedure say’s, that driver installed are newer then the one from Nvidia site. So i abort installing. Very starnge to me is also, that there is no OpenGL Control Panel or something i could change/look current OpenGL
parameters…all my older PC’s have some kind of control panel…does NVidia do not have OpenGL control panel ?

Thanks, Elixer,

vsynch is off. Seems that DirectX working well. Testet it with 3DMark.

I don’t know, what i should do next…