GeForce 2 OpenGL "Choke"

I have a problem with my Geforce 2 card (Hercules). Occationally, but persistently i will have a small choke in open GL which generally makes my view shift (up mostly) and keys random buttons (usually use item or switch weapon in Q3A). It happens less often when i turn video quality down, but still consistently. Is this a hardware problem, a OpenGl bug, or something else?
-Jason M.

Well… i got two questions:

  1. Does this only happen in Q3A?

  2. Did this happen when you first installed Q3A, or did it start happening not so long ago?

IF ANSWER TO #1 is YES: you could try updating to the latest point release.
#1 NO: Try to get newer or different drivers for your card.

#2 YES: same as 1, get the newest point release.
#2 NO: Get + run the Quake III Point Release Switcher ( <— heres a link). And return to the previous point release when it worked.

No, the exact same thing happens in UT and HL as well. I have the newest drivers for my board. I believe that it also works with the nvidia detonator drivers as well as the propritary Hercules drivers. it did the same thing in WinMe as it does currently in Win2k. The more i think about it, the more it sounds like a hardware problem. Any other help will be nice.

Well now that you clarified everything, it DOES sound like a hardware problem.

The only way out of this problem i see is to buy a new vid card… but i know most people won’t do that, especially w/ a geforce 2 cause its a good and $$$$$ card…

To really find out if your vid card is bad… this is the only thing i’ve thought of:

If you have a REALLY good friend with the same vid card you could try borrowing/using his card and see if the same problem pops up (if it does, its probably a mobo prob, if it doesn’t, its your vid card).

OpenGl throttling is a common problem in Pentium 4 line of chips. I think the problem is visible in the range of 1.2 to 1.5 Ghz P4.

Well, let me correct my statement. It’s not openGl specific. I think it is Game specific and Q3 is definitely one of them.

[This message has been edited by bivasb (edited 09-28-2001).]

what internet conenction do you have? this can be why you get choke Q3A or HL. Also if the transfer rate in the in-game console isnt correct for you connection it can choke and become irritant.

Perhaps. What’re your system specs? If you have a small amount of RAM (Q3A needs at least 128 megs to paly nicely afaik), of course it’s going to choke. It may also be due to texture loads. That REALLY causes your machine to choke, especially if you use AGP speeds lower than 4x (hehehe, that’s the best they have now). What controller do you use? If it has less than choke-tolerant drivers, it might cause an upward drift… I think I used to have a stick that did that… Didn’t physically last long either, so I got an MS PPro and am now quite happy

First, Hardware Specs:
ABit Athalon MB, 100Mhz FSB
800Mhz Athalon (slotted)
AGP 4x Geforce2 60meg (Hercules propritary board)

640MB Ram

The exact program, which I know happens in both Q3A and HL (possibly UT), but only in OpenGL mode, is occationally the screen will jump straight up, and change weapon. I have used multiple different configurations, including different buttons for weapon switching, and inverted and standard mouse, but it always switches weapons and moves view up.
I am on a Backbone connection (T3 or OC3, not sure…but connection is not a problem…ping never above 50)
Tried both propritary (Hercules) and chipset (NVidia) drivers, both do it in opengl.
Im guessing it is a hardware problem…but i dont know where…the board works fine in direct3d mode. could it be some of the video/AGP settings? bus/irq settings? OpenGL setting?
Any ideas?

I had 756 mb of ram and got similar chokes or jumps to windows in hl cs then after weeks of solving this prob I tried limit the amount of ram from msconfig (it’s under advance tab) to 512mb cause windows won’t understand more then that, but it didn’t help with me so I manually removed one 512 mb block of ram and it runs now fine with my config which is
geforce2 pro 64mb
msi @ 1ghz (there is via updated chipset)
256 mb of ram
! windowses from 95 to me atleast won’t udnerstand more than 512 mb of ram

ok listen when i open my counter strike or open a game in full screen i see a big black thing thats just sitting there pointlessly and im getting quite do i make it go away?!