Geforce 2 mx 400

Can someone please help? I have tried unsucessfully for about 2 months to have opengl hardware acceleration, but it never works. How can i setup opengl hardware acceleration for a geforce2 mx400 with 64 mb of ram?


Go to and download glsetup. This program detects your video card and will install the proper opengl drivers for your card.

i donloaded brand new drivers from nvidia, but in the display properties, under the list of filenames, for nvopengl.dll it just says ‘installable opengl client drivers’ how do i install them? gl setup said i already have better drivers than i could download from them.


“Installable Client Driver” is simply the architecture name for a full OpenGL driver. I’d bet you’ve seen “ICD” before. Well, now you know what it stands for. This just means that you have an OpenGL driver file installed.

I suggest that you give us some more details about what problems you’re getting, exactly.

Details of the problem…

I’ve tried downloading opengl, i’ve done the glsetup, ive got the drivers from

Quake 3 won’t run, (opengl mode not supported)

Serious Sam won’t run, (opengl mode not supported)

Half-Life won’t run in opengl, (opengl mode not supported) in any resoolution.

I wrote some programs in opengl, and those run, but with a horrendous framerate. (5-10 fps) whereas my friend can run it with around 150 fps.

i have an amd athlon 750, with 320 mb of ram,
and my friend has a pentium II or III, with 256 mb of ram and a voodoo 2.

I don’t get any error messages, and i can hear the moniter or something kind of clicking, and the moniter flickers as it tries all the resolutions, but it just says ‘open gl mode not supported.’


I have the same problem…

when launching Q III, the error message said : “couldn’t load open gl subsystem”…
hope this could help…

Quite simply, opengl does not work in hardware accelerated mode. I have no idea why it doens’t. I geforce 2 mx400 has opengl hardware acceleration though. I just don’t get it.

Thank you everybody!

conrad, that’s a completely different problem. Search the forum (for that error) for solutions.

fredowl87, sounds strange. You definitely don’t seem to have OpenGL support. All I can guess is that something is interfering with OpenGL. Could be a wrong OpenGL32.dll that somehow got into your path, or could be that the system is looking for some reason at some old OpenGL ICD that belongs to an older graphics card you have.

Can’t be sure. Did you have another card before the MX400?

Before this i had a riva tnt2 which i don’t think has any hardware opengl acceleration. At least, it didn’t work with that either.

If it helps, im running win98

Thank you!!!

The TNT2 should support OpenGL just as well as the MX400. Seems like some deeper problem. Have you tried reinstalling Win98?

I havn’t tried that yet. Think it will work?

Could it be a hardward problem, but not with my video card?


If Direct3D works can you first check your win.ini file for a line with DVA. Remove that line if you find it.

The “reinstall Windows” solution is just a generic one that might help. I lost Direct3D (or rather, texturing in Direct3D) in Windows 2000 and a clean install solved the problem. Nothing else I tried solved it.

the dva thing will work?

thanks everybody!

I am having the same problems. I have an Inno3d MX400 card with dual monitor outs. When i enable the second monitor to have 2 desktops, OpenGL screws up. When i disable the second one, OpenGL works fine. You may want to try this if you have 2 monitors. Hopefully this issue can be fixed in OpenGL 2.0!!

I’m to having some of the same problems. I’ve got a Geforce2 64mb/400 mx PCI card And when I try to use OpenGL with Baldur’s gate 2 Nothing happens. I’ve downloaded the latest drivers and directx8.1 So I believe I’m up to date with everting. Now, i don’t no very much about openGL yet, But I’m just having alot of troubles.
(That Lord of the rings screensaver won’t work either.)
I’ve downloaded GLsetup95 (?) PLaced it in c:\windows\system\ it doesn’t seem to make any difference. And I don’t have access to the internet with my own computer. Is there any hope for me



I’m running winXP and openGL only worked for HalfLife games and no other opengl game engines. I have 21.83 ref drivers on a GeForce2 mx and an Abit mobo (900mhz Tbird).

I found a solution to my problem by slowing down my AGP vid card to a 2x rating in the BIOS!

Now all the OpenGl games work! So it seems that by slowing down my mobo opengl engines handle better. What motherboards you guys have? Chipset? Via updates allow you to slow down your agp port to STANDARD ! That worked under win98se with an FIC mobo.

Try it. If nothing happens you can always return to 4x. The performance hit seem minimal.

hey, that dva thing worked!!! I’m so happy!!! BrokenRubber is A Stud!!!

I have same problems but i’m under WindowsME.
I can’t find the vba line in win.ini with this OS.
Any Ideas ?

I tried to install new drivers, glsetup, reinstall all drivers properly it’s the same.
My OpenGL games always crash with GLW_StartOpenGL() - could not load OpenGL subsystem

I have also a Geforce 2mx 400 but i find on forums that a lot of people with different boards have same problems …

Games that use OpenGL for 3dfx that exist doesn’t work with GeForce, you should use OpenGL defaut!