ge2 normal problems

I am loading a ge2 file exported from maya. I am loading a sphere among other objects, and have a problem with the normals. Here is a pic to show the problem.

Is this problem related to the ge2 file format, because there is no reason that this should be happening?

are you sure your normals are normalized
(0.0 to 1.0)?

Yes, they are normalized.

I found, that I’ve got similar artifacts with model , where I had normals pointing INWARDs (to the invisible center of object),
but I don’t know if it can be similar or how can it happen during export (my model originated in 3d studio,but I exported it into pure gl c code)(but I would trust maya doing things right)

i wasn’t able to download ge2 opengl loader,
cause that seems stucked for me, but I’ll try do it later.

[This message has been edited by tachyon_eagle (edited 02-15-2004).]

No, I tried to reverse the normals and that didn’t help (it made it much worse). Half of the triangles on the top half of the sphere are correct, however the other half of the top and the whole bottom are flipped (as in the top part of each triangle is dark, where as the bottom should be). I tried rotating the normals around and that didnt help at all. As far as I can tell it’s a problem with the ge2 file format. Any ideas?

From the sphere screenshot, you can see that it is just the order of the normals which is incorrect.

For the lower part of the sphere, try to exchange the normals of the vertices …well, it is time for some ASCII graphics :

before :



after :



I often found that exporting from 3d packages like 3dsmax or maya can give unexpected and intriguing results…

[This message has been edited by ZbuffeR (edited 02-15-2004).]

3D max uses a different coordinate system.

The negative z axis in opengl is the positive y axis in 3D max and the positive y axis in opengl is the positive z axis in 3D max. the x axis is the same.
In other words: y and z are switched and the (negative openGL) z axis is negated.


OK, I fixed the problem. I have to select “reverse winding” when I export out of Maya. Thanks for the help, this forum is definitely the best I’ve ever been to.