Game freezing - XP - GeForce

I hope someone can help me.
Ok I’ve downloaded and installed the new drivers 23.11 from Nvidia and also tried 21.83, BIOS are updated, I looked for and do not have the line DVA=0. After installing new drivers RTWC loaded up fine, I was happy until… after a few minutes of playing, maybe 5 at the most my computer screen froze and the music was playing like there was nothing wrong.
I was completely locked out, no ctr-alt-del would save me, only resetting would end it.
No matter what game I play RTWC, Unreal Tournament, Crimson Skies or The Sims, the computer screen freezes after a few minutes. Does anyone have any type of solution for me?
I just installed a Dazzle video capture device and the same thing happens with that. As long as I don’t play any games or try to capture videos XP is a great upgrade from ME.I don’t always have to reboot when I crash, sometimes XP takes forever to shut down…
One other question… what kind of systems are other people running that are NOT have any types of problems. Meaning you can go out and buy any type of game, load it up and play until you get bored with it?
Would appreciate any help.

OS-XP Home Edition
AMD Athlon Processor
948 MHz
256 RAM
Nvidia GeForce2 MX/MX 400

I didn’t like having to do this, but try it. It allowed me to play games like the Sims and Age of Empires after having freeze-ups.

Right click on your desktop screen, click Properties. You will see the Display properties menu. Click on settings. Make sure your settings are 800 x 600 and Medium 16 bit color quality. Then click on Advanced. Click on Troubleshooter tab. Move your hardware accelerater down to none. (I actually took mine down to the notch right before none and my programs work, but if you still have problems – defintely take it to none.) Make sure the enable write combining block is unchecked. Click apply and ok.

This should stop the lockups, but someone out there may know a better way so that you don’t have to disable your accelerator.

I have read also that you should make sure your monitor refresh rate is set at 60, which is standard, but I haven’t found that to be necessary in my case.

I got that problem to!!

almost all my games freez. The only one that not freez is Dave Mirra, and Im getting tired playing that game all the time!

NOLF, RTCW, Quake 3, Fifa 2002, monopoly Tycoon, Harry Potter +more doesn’t work.
If someone knows how to solve this problem, please reply!

look, ive got the solution to your problems, but i will have to send you some files that i dont have the urls for, if you want me to help email me at