G:_POINT_SPRITES textures order


when i draw textures in sprites extensions, they have this order - the texture which was drawn at the end is always first …

So when i rotate my scene (also in z direction), the texture with biggest depth is first …

How can i change that ? Is this a matter of sprites or texture ?

thx for help :slight_smile:

It’s not quite clear what you’re seeing and what you’re doing that’s causing the problem. But assuming you are properly drawing the particles at distinct eye-space Z values, which end up between the near and far clip planes, then sounds like you don’t have depth writes or depth testing properly enabled if the last particle you render is always on top:

glDepthMask( GL_TRUE );
glEnable( GL_DEPTH_TEST );
glDepthFunc( GL_LESS );

Thank very much Dark Photon :slight_smile:

I’ve tried some options with depth, but havent been able to accomplish … with you’re help it,s working just excellent :slight_smile:

I have to read more about depth :slight_smile:

thx and have a nice day :slight_smile: