Fullscreen with 120 DPI Font Size Issue...

I’m having a problem (Currently just with frets of fire, haven’t had time to test anything else) where due to having my Font Size in Vista set to 120dpi whenever I fullscreen, it increases the application size beyond the edge of the screen.

Other than setting the Font Size back to 96 DPI, is there any way to stop this from happening?

Is that really the window that goes beyond, or just the fonts in the window ?

The entire window. I have a 2 monitor setup, the second display usually shows part of the right side of the window, and I cant see the bottom of the screen on the first monitor either.

Add note: Same issue in “Gish”

Anyway to emulate opengl with directx or something? Might start looking into 3rd party programs to make my text bigger with high resolutions.

For anyone else with this issue in Vista, right click the program exe, go to compatibility, tick the check box “Disable display scaling on high DPI settings”, apply and ok.

Pretty simple, should’ve looked there earlier.

Wow, scaling on a fullscreen window is pretty stupid.