FSAA rendering problem

Hello guys,

I wrote a small tutorial for myself that renders a triangle with FSAA. I have the NVIDIA FX 5700. I use GLFW (do all the windows stuff) to define a rendering buffer with say 16 samples per fragment.
When I render the trig I do see smoothing along the trig’s edges with the backgroung. The problem is that I can’t turn off the multi sampling rendering by calling glDisable(GL_MULTISAMPLE_ARB).
It seems that glEnable/glDisable with GL_MULTISAMPLE_ARB dosen’t work. Once the multisample buffer is defined, I can’t return to normal rendering.
Do I miss something trivial?

I too would like some clarification on how exactly this works. For instance:

(Note: scroll right; above pic contains 3 sub-images)

This is with the latest NVidia drivers (169.07) on Linux on a GeForce 6800. __GL_FSAA_MODE=0 is FSAA disabled, whereas 4 is 4x Bilinear Multisampling. All were rendered to a window allocated in a 4X MSAA visual.

It appears that glDisable( GL_MULTISAMPLE ) only disables multisample “rasterization” (as the spec says) but it does not disable multisample “downsample filtering”. Is this correct? And are there any OpenGL-defined controls for modifying the latter?

Don’t think so, but I wanted to double-check.

yossi, I don’t know if this is your original question, but if not please clarify.

Thanks Dark photon for your reply and HNY to you,

I get more or less what you have sent as images. When disabled and GL_FSA_MODE is 4, still there is smoothing of the edges. I thought I would get no smoothing at all like in the left image