Frustum culling doesn't increase FPS

If you’re sure about the unit, that means a 188 fps max, provided that all of the rest of your program runs at lightspeed.
You should compare your timing with FC enabled and disabled and see if that’s profitable to enable it. But to my opinion you’re bounded with your frustum culling.

Also have a second regard about the comments of the other posters. Your bottlenecks are most probably elsewhere for the moment. You’ll have to find where.

You are right. With anti-aliasing off, shadows off, and water off I can get max 180 fps. I found what is causing the problem. It’s the cascaded shadow map. When it is disabled I have average of 150 fps. When I enable it it drops to 50 fps… Sorry for the fps but it is easier for me to report those than the timings.
So I have something wrong there. I use 3 cascades are those many? It means 3 shadow draws per cycle. Also can I make it with one draw call using the GS to generate all the different view spaces? Will this improve the performance?