Freezes when using WebGL


I’ve started playing with WebGL a while ago, with a Firefox Minefield build and Chrome 5 on Ubuntu 9.10. It worked just fine then, but other projects got in the way and I forgot about it for a while. Yesterday I decided to pick it up again, having upgraded the OS to 10.04 / Lucid Lynx in the meantime, and now I’m getting weird program freezes (mostly the browser I’m using, sometimes the IDE as well, and sometimes the whole system hangs up) when using WebGL. The driver for my ATI cards is fglrx, browsers are still the same. I’m using the CopperLicht library. Sometimes the freezes occur as soon as I try to load WebGL content, sometimes it works fine for a bit and then freezes. When not using anything WebGL related, the system is fine. E.g. Blender works flawlessly.

Any idea what could be causing this?

are you running out of memory?

are you running out of memory?

I wouldn’t think that to be likely - at the time only an IDE and a browser are running, and the machine has 4 gigabytes of RAM. I will check memory consumption, though - you suppose there could be major memory leakage?

Some more information about the machine: it’s running a 64 bit Ubuntu Studio 10.04 install, and it’s got two graphics adapters (ATI HD2600 and ATI HD4350) running three screens total. Device driver is fglrx.

I’d consider downgrading to 9.10 again, although I will have to finish some other projects first. And I’d rather get WebGL working for me in 10.04 as well, really.