FreeBSD OpenGL problem

I can’t figure this out. I got X 4.0 on FreeBSD 4.7 working with the Sawfish Gnome wm, and then I added the lines for glx and dri in the config.
These are working as per the instructions I found in the XFree86 web page (I used their tests and dri is in the libraries, etc.)

I compiled and ran, without errors, NeHe lesson 2, and the first two examples in the red book (OpenGL Programmers Guide).

My problem is that nothing is displayed, even though all my colors are white!

The red book example 1 has the background showing through the window, and the NeHe lesson2 goes fullscreen and even exits on ESC, and the red book example 2 actually is clearing the window as the background is NOT copied…

I have tried adding the NoAccel option to my config file, but still no dice.

What could I possibly have missed?

Oh yeah, and I am using an AGP ATI Mach64, but like I said before disabling hardware acceleration didn’t help.

This might have nothing to do with yuor problem but I think that there is no DRI in freebsd.

I installed FreeBSD 5.0 DP2 and the problem disappeared…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.