fragment program problems

Alright, i have some issues with the fragment program. Ok, I can load up a program, and have opengl parse it for any errors. It won’t give me any errors in the program. Then, I’ll bind the fragment program, still no errors. Then, when I call the drawarrays command, I receive an error saying memory could not be read. It is the same error I get when I try to run the NVIDIA Dawn and Ogre Demos.

Now I’m frustrated, because I bought a GeForce 5600 FX partly to be able to use fragment programs, and I cannot seem to get the NVIDIA demos or my programs (that try to use fragment programs) to work. Any suggestions? Why can’t I get the fragment program to work? I’ll gladly provide any more info if needed, I just want to get the darn thing to work!

Originally posted by yoale:
Any suggestions?

Well, what do you usually do when things that SHOULD run doesn’t? Test other games/demos, check video driver, check agp driver,event viewer,googling for error,[insert own trial and error approach here].

That’s odd. There is a couple of other people having a similar problem with the same card. Sorry, I don’t know what the problem is.


Have you gotten it working yet? If not, please post more info. Sounds like a driver version problem, but I can’t really tell without more info.

Thanks -


I have installed the 44.03 Detonator FX drivers. I have also tried updating my system BIOS, to no avail. I have an Athlon 1.3 GHz w/512 MB DDR PC2100 266MHz RAM. I am using Windows XP Home Edition. I also have Directx 9.0, and have tried DirectX 9.0a. I even contacted Compaq the manufacturer of my computer, but they said they never experienced the problem before.

I don’t know what the problem is. I have tried two different GeForce FX 5600s, one from PNY, another from BFG. Everything seems to work fine, TV in-out, vertex programs, games such as Unreal Tournament and WarcraftIII. The only thing is fragment programs don’t work and the Dawn and Ogre Demos that came with the cards. I hope this helps you. Thank you all for your time. It is greatly appreciated

I really want my program to be able to use the new technologies such as fragment programs, but I’m having a hard time.

Also, when i run my program, my MS Visual C++ 6.0 debugger says the error occurs in nvoglnt.dll. When I get the error in the Dawn and Ogre Demos, I cannot tell which module caused it (disassembly code I do not know).

I believe the drivers are using SSE instructions, and I believe your Athlon is not the “XP” version and thus it doesn’t support SSE.

So, does that mean fragment programs will not work on a regular Athlon, they will only work on Athlon XPs? If that is it, then I’ll at least have closure for my problem. I just can’t use a Geforce FX because I don’t have an Athlon XP. If that is the case, I’d love to hear from an official person from NVIDIA. Thanks again for all your help.

Originally posted by yoale:
So, does that mean fragment programs will not work on a regular Athlon, they will only work on Athlon XPs?

Fragment programs work great on my fx/athlon-1gz system(T-bird). Try running some fp demos that doesn’t require SSE/SSE2. might have some.

Also, when i run my program, my MS Visual C++ 6.0 debugger says the error occurs in nvoglnt.dll

Run your app in debug mode and step through it. Find out what gl call makes your app crash.

[This message has been edited by roffe (edited 06-20-2003).]

jwatte (or anyone else ), do you know of any patches/fixes/versions of the Dawn and Ogre Demos that do not require the SSE instructions?

Oh, and by the way I believe I MAY have fixed my fragment program problem in my code, but I’ll keep you all posted. Thanks again

[This message has been edited by yoale (edited 06-20-2003).]


Now I’m really confused. I thought I got the fragment program code working. What is wierd though is that it will only run for about 30 seconds at most, and then it just crashes and gives me an error in nvoglnt.dll. It does this every time I run my program.

I know it only happens with the fragment programs, because the entire program works as expected (at least on my machine ) when I comment out just these two lines:

//where fprog is the fragment program id

I know by commenting these out (they are in only one place in my program) that I’m not using a fragment program, just default OpenGL. And I still cannot get those Dawn and Ogre demos to work.

Also, I was wondering, does the driver reside in card memory or system memory when it is loaded?


[This message has been edited by yoale (edited 06-21-2003).]

Ok, so what’s the error. What’s the line where it halts in nvogl?
If SSE is the problem, then turn it off from the nvidia control panel.

Well, here is the error:

The instruction at “0x6964b774” referenced memory at “0x11bdd000”. The memory could not be “read”.

For whatever reason, certain memory locations cannot be read. Sometimes the locations change, but the error stays the same. On the OpenGL options tab, I checked the box marked “Disable Support for enhanced CPU instruction sets.” It still gives me the same error.

I shouldn’t have such a hard time to get a graphics card to work, should I? My GeForce 2 never gave me any problems, but then again it cannot do fragment programs either. And it only has two texture units.

[This message has been edited by yoale (edited 06-21-2003).]

Just for fun, I just tried switching out my system RAM modules, and I still get the same error. Hmmm… Could all this hassle be over a bug in nvoglnt.dll maybe?

Get same errors I got in the Dawn and Ogre Demos. Although I still get the same error in my fragment programs (after about 20 seconds), I don’t know if it is the same error that causes the demos to crash. Please help, it is OpenGL related

[This message has been edited by yoale (edited 06-21-2003).]

If it does run for 30 seconds, and then crashes and it looks like SSE is not it … I dont know what to tell you. It looks like the driver is at fault.

Maybe someone who has the same card is beeing able to run the demoes?

You can try running something more basic than Ogre and Dawn. Maybe a something with less than 10 instructions

MOV result.color, fragment.color;

Can’t get more basic than that!

heck, this all reminds me that nVidia RivaTNT bug on win98SE last year – it just ate my time in vain Still got the tremor when recall it…