Flightgear W98 Stealth III S540 Help

I am trying to run FlightGear the OpenGL based open flight simulator on a PC with the following specs:

Operating system: Windows 98 Version 4.10

Computer: AuthenticAMD K6-II 266 MHz 3D Processor 64 MBytes RAM

Graphics board/chip: Diamond Stealth III S540 AGP 32 MBytes RAM Controller S3 Savage 4 Pro+.

Video Adaptor Device: Diamond Stealth III S520/S540 for Windows 95 with driver details
reported as STL50016.DRV, STL500.VXD, vmm32.vxd (vdd.vxd) and vmm32.vxd (vflatd.vxd). (By the way, it may be relevant that although by graphics accelerator is AGP the software CD-ROM used to install its software has PCI marked. I discussed this with my supplier and he explained that the original AGP disk was deffective and as there is no practical difference between AGP and PCI drivers he used the PCI disk. Whether there is or there is no real difference I am not in a position to say.)

Compiler/version: I am using the compiled version by downloading the files fgfs-base-0_7_6.exe, fgfs-manual-0_7_6.exe, and fgfs-win32-bin-0_7_6.exe as per GetStarted guide.

Versions of relevant libraries: I assume none is needed to run the compiled version.


I have downloaded the three required files for the already complied version (at least this is what I understood to be doing) fgfs-base-0_7_6.exe, fgfs-manual-0_7_6.exe, and fgfs-win32-bin-0_7_6.exe from FlightGear site. I have extracted the files from the .zip pack to folder


and then tried to run c:\FlightGear\runfgfs.exe from the Windows Explorer by double-clicking runfgfs.bat as under item 9.4 of Getting Started but the batch program shows as last processed line:

WARNING: ssgLOADOBJ: Failed to open './Models/Geom_

and then stops. I could not change windows but could move the mouse. Twice I’ve heard the purr of an aircraft engine though briefly. Once the launching problem completed the line but stopped all the same.

I have checked troubleshooting sections of the graphics accelarator board, of FlightGear Get Started guide and of www.opengl.org. I have also downloaded a small program called GollyGee Blocks (Demo) from a list on OpenGl site in order to test the accelerator outside FlightGear. This software runs although crashing if I try to rotate a world with trees (just in case a charitable souls knows it or downloads it for reproducing my experiment. I have also downloaded a larger software called Armagetron which failed to run at all. (But the maker makes it clear that the game was developed for Linux and is unstable under W98.)

I trust the seller to have installed the board all right which leaves me with driver issues.

On my first try my system had Windows Opengl32.dll last modified on 05.05.99. Following instructions on OpenGL page, I downloaded and run a driver update batch from Microsoft server but am not sure I had this installed on the correct folder. (By the way, I cannot locate the executable file I’ve downloaded.) The then extant Opengl32.dll was replaced by an older version (last modified 07.29.1996).

Interestingly enough, when I next tried to run FlightGear, the DOS batch run all right and a white full-display window appeared, the purr of engine was heard and the rest was silence. I had to reboot the system. On the second try two greyish rectangles appeared on each side of the window and a thin line came down from the top to a little lower than midscreen. Some progress but it was all. Incidentally, I had to load GollyGee Blocks with more image elements before it crashed but Armagetron still doesn’t run. (Actually it seems to run and shut itself off immediately).

My next step would be to run GlSetup. However because of the many chances of problems with the system they advise users of, I decided not to take any risks for the moment.

Any indication of what may be wrong with my system or where to go to find the correct drivers or anything else needed will be highly appreciated.