Hi, just installed the latest NVIDIA linux drivers. Can not figure out how to turn fast writes on. Both card and host bridge support it. Howver, the driver faq says the driver may turn it off to favor system stability. Is there any way to override this? I thought it would be as simple as editing the XF86Config-4 file but I couldnt find any commands relevant to fast writes. Thanks for the help,

Old GLman

this is the way I enabled it :
add to your /etc/modules.conf:

“options NVdriver NVreg_EnableVia4x=1 NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1”


Ah, cool stuff. Thanks man.

Old GLman

any other way is to stipulate it in os-registry.c file of your nvidia sources.

I installed the latest XFree86 4.2.1 and everything is ok. Now when I go to install the NVIDIA GLX package is says it needs XFree86 greater than 4.0.1, which I have. Anybody know what the deal is?

I apologize for this not being apart of my orignal post. Curiosity overcame me and I found myself reinstalling linux.

Old GLman

If you mean by GLX package the GLX rpm and if you installed your new XFree86 not as a rpm package then rpm doesn’t know that you have any version of XFree since it only checks for package dependencies.
Just a thought, perhaps some details about your XFree installation and which GLX package you tried may help.
And btw reinstalling the OS should be a Windows only method for solving problems

just fixed typos

[This message has been edited by satan (edited 10-18-2002).]

Like many problems, the solution was simple.

rpm -ivh --nodeps NVIDIA_GLX-1.0-3123.i386.rpm

Sometimes I wish I knew twice as much about linux as I do currently. sigh

Old GLman

Originally posted by Old GLman:
[b]Like many problems, the solution was simple.

rpm -ivh --nodeps NVIDIA_GLX-1.0-3123.i386.rpm


I won’t call this a solution but a workaround because you just told rpm to ignore dependencies.
I don’t know how much you know about Linux but when using nodeps you should know what you are doing. Before getting too much off topic on this board i stop here, because rpm and its behaviour can lead to very long discussions.

Hey, I completely agree. As far as Linux goes I’m still new. I know my problem wasnt solved, what I did was just a workaround. I know I have a bigger problem because every time I try to verify or query the GLX rpm it just tells me its not installed. Its really wierd, but I’ve checked that the drivers were installed ok and all that, and everything works great. Id like to think its an rpm problem, but I really dont know.

Old GLman

The NVIDIA_kernel rpm installed without any problems?
If your GLX rpms is installed but can’t query it then it may be a problem with your database.

First try rpm -qa which shall give you all packages installed on your system.
If this fails you can be nearly sure that it is a database problem.
Then you may try rpm --rebuilddb so that rpm tries to find all installed packages and builds a new database on this information.

This is all I can think off at the moment.


just look at glxinfo… if it says youi are accelerated with NVIDIA glx… then its OK and do not touch anything else. If not… best to do is install all over again.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.