ext doesn't work although supported

hey,

I just queried all my OGL details and it says I’m running on version 2.1.8193 and glGetString(GL_EXTENSIONS) put out GL_ARB_shader_texture_lod.
But once I try to compile a fragment shader with this in its header:

#version 120
#extension GL_ARB_shader_texture_lod : require

the shaderInfoLog tells me that this extension isn’t supported. Am I doing sth wrong? I’m running on a ATI Mobility Radeon 3400 Series.

I can’t find the same info log. Did you compile the shader with the header and then get the info by glGetProgramInfoLog?