Experiencing issues with all things Vulkan related! :(

Hi, was hoping for some direction! I recently obtained Red Dead Redemption 2 and if I run it in Vulkan mode, I run into all kinds of issues. My Rivatuner overlay begins flickering horribly and when I run the games benchmark, fps drops to 18fps and within a few frames the entire game hangs. If I run the game in DX12 mode it is fine. I tried another game which runs in Vulkan API but has worked perfectly in the past, Doom Eternal. The game will not even boot! I am running Windows 11 and using 2 x Titan XP in SLI mode. Any thoughts? I am guessing something to do with Windows 11/Vulkan and SLI perhaps? I have tried other games that have good SLI scaling and but do not use Vulkan like Shadow of the Tomb Raider and Vermintide II and both work perfectly so it can only be Vulkan related.

Vulkan is not some kind of packaged end-user product, and this forum is frequented by programmers, so there is only so much that can be done here for you.

If your overlay misbehaves, then you need to talk to the overlay makers, not here. Or for starters, you can try to uninstall it if it makes it work.

If your driver misbehaves, you need to talk to NVidia. For starters make sure you have the latest drivers installed.

If your game misbehaves, you need to talk to the game maker.

If you suspect SLI, you can always try solo GPU to eliminate\confirm that possibility.

You can try to run vulkaninfo (it should already be installed with your driver) to check sanity. If your install is correct it should barf out a long output, there should be no ERROR stated in there, and it should list only the two GPUs you have and no more. Additionally, you can try GPU Caps Viewer. Go to the 3D Demos tab, and run the Vulkan demos if they have any problem too.