ERROR: Missing GL version

I’m a beginner programmer trying to get my first shader to run in my OpenGL application.

I have included <GL/glew.h> (before glut), installed the dll file into SYSTEM32, the glew32.lib in LIB and glew32.h etc in include. I have also set linker to read glew32.lib

I run this code in my main function to identify the problem:


int main(int argc, char *argv[])
glutInit(&argc, argv);

GLenum err = glewInit();
if (GLEW_OK != err)
	fprintf(stderr, "Error: %s

", glewGetErrorString(err));
fprintf(stdout, "Status: Using GLEW %s
", glewGetString(GLEW_VERSION));

…etc etc…(but it doesn’t get this far)

it returns the error message:

ERROR: Missing GL version

I’m really stuck as what to do now, any help would be much appreciated.

Thanks :confused:

You have to initialize glew after you have created OpenGL context.
So you must initialize glut, create window, and then initialize glew.

That’s brilliant! It worked, thankyou very much for that tip.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.