Error: GL 1.1 and up are not supported

I’m a beginner programmer trying to get my first shader to run in my OpenGL application.

I have included <GL/glew.h> (before glut), installed the dll file into SYSTEM32, the glew32.lib in LIB and glew32.h etc in include. I have also set linker to read glew32.lib

If I run this code in my main function to identify the problem:


int main(int argc, char *argv[])
glutInit(&argc, argv);

GLenum err = glewInit();
if (GLEW_OK != err)
fprintf(stderr, "Error: %s
", glewGetErrorString(err));
fprintf(stdout, "Status: Using GLEW %s
", glewGetString(GLEW_VERSION));

…so on ------

it returns the error message:

ERROR: GL 1.1 and up are not supported
I need your help. Really thanks in advance.

glutInit() does not initialize OpenGL, glutInitDisplayMode() does.
glewInit() has to be done after that.

glutInitDisplayMode doesn’t either, you need to wait until after glutCreateWindow…

This error can also be caused by using an old version of GLEW with an OpenGL 2.0 driver.

Really thanks,
I finally solved the problem.

Yes, It was the problem using an old version of GLEW with an openGL 2.0 driver.

really thanks.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.