Email conversation with EA Tech

Ill post what EA will tell me here. Hopefully they will come up with a solution that will fix my problem with MOHAA.

Im noty getting these “Couldnt load OPENGL subsytem” errors i just cant play the game because whenever the loading bar appears for the level it just crashes back to the desktop.

HERES what has been going on so far with my email to tech support.

Customer 08/17/2003 06:34 PM
I have closed all programs running in the background. I have left only explorer running after i shutdown taskmanager.
This has not helped. The game still doesnt work. The same thing keeps happeneing. The loading bar for the level appears and then it crashes to the desktop.

I made sure to disable all autostarted programs so that i could reboot and try again. The game did not work.

I dont get it. Why?
Every other game I have works except this one. I thought it may have been damaged cds but I have already returned and received a new set from GAME.

Response (Box Ivan B.) 08/17/2003 05:41 PM
Make sure that you have closed any programs or tasks running in the background as sometimes one of the programs can conflict with the game. Background applications such as anti-virus programs are often the cause of conflicts.

Hold down the Ctrl, Atl, and Delete keys at the same time
This will bring up the “Task Manager”, follow the steps bellow in order:

  1. Click the “Processes” tab.
  2. Click on the gray bar that says User Name to sort by user name.
  3. Do NOT select anything for SYSTEM, LOCAL SERVICE, or NETWORK SERVICE.
    Click on anything besides EXPLORER and TASKMGR for this User Name or other user names.
  4. Click on END PROCESS
  5. Repeat steps 3 and 4 until only explorer.exe and taskmgr.exe are open for this user profile.

Customer 08/17/2003 01:17 PM
I have already updated my motherboard drivers with the hyperion drivers. The game still doesnt work. My system is fully upto date like i said in my email. Nevertheless I have installed the drivers again as you have suggested from the link you provided. MOHAA still doesnt work.

There must be a way for you guys to recreate this problem with any systems you have to try to fix this. Im not the only one who is having this problem.

Response (Box Ivan B.) 08/17/2003 11:40 AM

Thank you for contacting EA Technical Support. We will be happy to provide you help with the troubles and concerns you have.

After looking at your system information, I noticed that you have a VIA chipset. There is an update you’ll want to get from VIA that addresses a few known issues with their systems in particular causing lockups and other issues in several high end games.

This page has info that you should look into as a possible resolution to your issue. Unfortunately, I am unable to guide you through the setup of any of the software on this page as it is not EA’s product, however should you run into trouble VIA has Install guide and a Help Forum which should be able to guide you through the instalation.

Customer 08/16/2003 04:33 PM
Oh yes another thing I have forgotten. I have rearranged my hardware so
that the top PCI slot on my motherboard is free. I read on a forum that
this could cause issues with games.
Doing this did not resolve my issue.

I have little hair left on my head with regard to this problem.

Auto-Response 08/16/2003 04:17 PM
Title: Medal of Honor (PC) LOCKUP - Locking up on loading bar when trying to start miss

Title: Medal of Honor (PC) CRASH - Random Crashes or Reboots - ** VIA Motherboard **

Title: Medal of Honor (PC) ERROR - Could not load OpenGL subsystem - check video card

Title: Medal of Honor (PC) CRASH - Crash to the desktop after splash screen (Windows XP

Title: Medal of Honor (PC) CRASH - Crash to the desktop and dials up the ISP

Customer 08/16/2003 04:17 PM
Medal of honour crashes when the loading bar for the level appears.

This is what I’ve tried.

  1. Installing older drivers with Opengl 1.3
    (Didn’t Work)
  2. Uninstalled Drivers, Used Detonator R.I.P to completely remove drivers from my system. Installed the Drivers With opengl 1.3 in them.
    (Didn’t Work)
  3. Did the above with all the drivers in the nvidia xp drivers archive.
    (Didn’t work)
  4. Downloaded New OpenGL.dll & .lib, Overwrote the ones on my system.
    (Didn’t work)
  5. Uninstalled and reinstalled MOHAA and did all the above each time. Tedious & Boring.
    (Didn’t Work)
  6. Tried an NVIDIA refresh rate fix.
    (Didn’t work)
  7. Tried GLW Glide driver.
    (Didn’t work)
  8. Installed DirectX 9b, 9a, 8.1, 8 >
    (Didn’t work)
  9. Installed the leaked drivers for my GFX card. They are not even officially released yet. They are the Detonator 45.20 drivers.
    (Didnt Work)
    9.Lowered Resolutions and colour depths.
    (Didnt Work)
    10.Closed every application and process running in the background of my system.
    (Didnt Work)
    11.Lowered hardware acceleration for both graphics and sound.
    (Didnt Work)

None of the above has solved the issue.

My System is running at full potential. I tried that dxdiag and have updated all my motherboard drivers and BIOS’s. Including MY GFX cards. After the updates the system is running even faster.

MY Setup Is

AMD Athlon XP 2100+
512 DDR
Gforce Titanium 4200
MSI KT4 Ultra Motherboard with VIA Chipset
2 80gb Hardisks
Creative SoundBlaster Live

Every other game I have works like a dream.
The only problems I am having Is with Medal Of honour. When you buy a game you expect it to work. I took the game back and got a new copy. Still the same problems. Whats wrong with this I dont know.

Oh and by the way. You have my question down as solved when its not. I did reply to let you know but it appears that you did not receive this. This time I am sending my DXDIAG.