.dll problem with glut

I am new to glut and was trying to build a console application in VC++ 6.0 (on NT). I had no problems with compilation and building, but when I tried executing it, I got the message- “Initialization of the dynamic link library C:\WINNT\System32\DDRAW.dll failed”. The process is terminating abnormally."

Can anyone help me out- I believe I have all the settings etc. done right.

Thanks in advance

This won’t help you much, but my guess is that your OpenGL implementation passes things to DirectX, which isn’t fully supported in NT 4.0. I don’t quite understand why your drivers would pass stuff to DirectX if they were designed for NT, though. What kind of card do you have? Have you looked for the latest NT drivers for it? It might just be a matter of installing different drivers. Or I could be completely off-base and the problem is related to something completely different.

Also, do you have any of the NT Service Packs installed? I’m not certain, but I think the later service packs may have had better DirectX implementations. Still not complete, but better.

[This message has been edited by Deiussum (edited 11-14-2000).]