disappearing open GL under win2k

On my computer something strange happens. Always when I restart my computer my openGl stuff doesn’t work anymore. I tried a few versions of the “detonators” from nvidia. After install everything works. But after a reboot all opengl applications (3dsmax, Gl excess etc.) report that it’s not possible to initialize OpenGl.
I running a Win 2k Pro, SP3
on a AMD 900 MHz, 256 Megs of RAM, GeForce 256.
Does somebody knows the prob or can give helpfull tips? like install a perfect openGl enviroment on win2k?
Thanks in advance

I have a similar problem, but on a different (and older) configuration, WinXP (no SP), AMD K6-2 333MHz on ALi V chipset, 128MB of SDRAM, nVidia Vanta 16MB (i got this problems in Win2K to but not in Win9x or WinMe). I posted a topic here not long ago but no one answer, still i got some answers in the developer’s forum. One suggestion was to decrease the hardware acceleration notch to none, forcing the ICD to run in software compatibility mode, but that does resolve the problem only partially (it work for some CAD programs like Unigraphics or maybe with 3DMax, on 3DMax i used the Direct3D driver so i really don’t know) because the programs that require hardware OpenGL ICD refuse to launch.
So i tried to install different Detonator drivers and i got results with the Detonator 23.11 driver, but still i have some problems with some programs that require OpenGL (for example the game called Bridge Builder, after 5-10 minutes it gives me a blue screen with “nv_disp.dll” related exceptions), try it and maybe you get lucky or if you got some better solution please drop me an email…

Thanks for the post. I’ll try the 23.11 detonator and let you know the result.

there’s some trouble. nvidia doesn’t store the 23.11 driver anymore. So I uninstalled all my nvidia drivers (card and goggles) and installed older versions, but nothing changed. after reboot openGl won’t work. the “OPENGL32.DLL” is in my “WINNT\system32” folder. is this the only dll i need? and is a dll case sensitive?

My system has the same symptoms, haven’t found a solution for w2k yet. Under w98se, it works.

Originally posted by pt0LeMeuZ:
nvidia doesn’t store the 23.11 driver anymore. the “OPENGL32.DLL” is in my “WINNT\system32” folder. is this the only dll i need? and is a dll case sensitive?

As for the 23.11, you can find those on the net, for example at guru3d.com.
After the driver install, I always rebooted as suggested and OpenGL never worked – are you saying that OpenGL does work right after the install, before a reboot? Weird, gonna try that.
There is a second DLL in my WINNT directory, nvopengl.dll or some such. It is also listed as a driver component in the “cover” tab of the detonator control panel. If and when and by what this dll is used, I don’t know.
There is only one program that gave me decent error messages, the Heavy Metal FAKK2 demo. I don’t have them here, but it said something about “could not find a valid mode”. However, not of the “refresh rate fixes” that I tried yielded any result. :frowning:
Good luck!

System: XFX Geforce4 MX440SE 64MB DDR AGP card
in anAGP 1.0 slot on a Biostar M5ALA 2.0 with ALI 1541/1543 chipset,
with a K6-3 450 (AFX) at 500MHz (used to be K6-2 400 at 400 MHz – no difference),
with 256MB PC-100.

[This message has been edited by filo (edited 02-26-2003).]

Originally posted by filo:
My system has the same symptoms, haven’t found a solution for w2k yet.

The 23.11 actually works (with a bit of bludgeoning – told it to install for a GF2 MX400 instead of for the GF4 MX440 which I use but the 23.11 doesn’t support that directly), I can’t believe it. However, whether it works now due to the different driver of the different install method (Update Driver instead of InstallShield/setup.exe) or something else, I cannot say. Thanks for the tip, anyway.