Disable watchdog timeout for long fragment shaders

My fragment shader is performing a raycast through a 3D texture, with potentially many iterations of a “for” loop.

It works on Windows but crashes on Linux, and I believe this is due to a timeout occurring after a number of iterations. Is there a way to disable the timeout? I’m using NVIDIA hardware.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.