Depthmap: skip transparent pixels


At the moment, i’m rendering my depthmap to an fbo the standard way (GL_DEPTH_ATTACHMENT_EXT).
I have trees that consist of two crossed quads with transparency (alpha to coverage).
When i look at my depth map, the trees are displayed as quads.

Is there a way to avoid transparent pixels being rendered to the depth map?


enable alpha test.

How do i do this for the depth map?

glAlphaFunc(GL_GREATER, 0.5f);

right before any rendering.

Or I did not understood your question ?

no, you’re absolutely right

thank you !