Current Open GL drivers do NOT work for any of my games!!!

Okay, people, I really hope that someone can help me out!
I’ve tried everything, including re-installing the newest OpenGL drivers on my machine almost 12 times. It says that yes, indeed the drivers have installed successfully, however, although the machine says that they are present, whenever I run a program that needs OpenGL, it simply does not work with OpenGL. I can’t run Tribes 2 at all, Quake 3 gives me the OpenGL error, and even friggin’ Quake 2 doesn’t work when I try to use default open GL drivers. I started having a problem with this a few months ago and I am near giving up. I have no idea how to fix this and I’m at the end of my line. OpenGL used to work on my computer but now it SIMPLY does not. Someone PLEASE help me with this problem!!!

Inquisitor Kryptman

Windows can disable hardware support by putting in a line with DVA in win.ini. Remove that line if found and if that does not work should I try to reinstall Windows.