Could not load OpenGL subsystem

#1

When I try to start Return to castle wolfenstein it never starts but I get this text to screen. I use GeForce2 GTS 32Mb and WinME.

Every OpenGL game I’ve tried also gives me some error text. What can I do?

#2

we have the same problem

#3

I have the same problem and so does my friend, i cant find any help with this problem

#4

Same thing here, Quake 3, Elsa (aka Nvidia) Erazor X2, Windows ME.

I HAD a link to a GREAT FAQ page for Nvidia and Elsa card probs.

When I find the link, I’ll post it.

Peace

Zippy

#5

Originally posted by Zippy:
[b]Same thing here, Quake 3, Elsa (aka Nvidia) Erazor X2, Windows ME.

I HAD a link to a GREAT FAQ page for Nvidia and Elsa card probs.

When I find the link, I’ll post it.

Peace

Zippy[/b]

#6

Great i’ll join the club.
Has anyone contacted tech help?
Well i’m going to.

#7

Originally posted by Gamer:
[b]When I try to start Return to castle wolfenstein it never starts but I get this text to screen. I use GeForce2 GTS 32Mb and WinME.

Every OpenGL game I’ve tried also gives me some error text. What can I do?[/b]

i have the same problem just with a ati radeon mobility !
do anyone know a solution?

#8

I have the same problem. The sad thing is that I posted about this before, and others have said they have the same problem, but no one has an answer. I have searched all over the internet and cannot come up with anything. I wish someone could help

#9

Different Cards, but the same OS, I suppose. Could Win ME be the reason?

#10

see my topics

#11

I have windows 2000 and have the same problem.

#12

If anyone figures out a solution. Please email me drlowe68@hotmail.com
Thanks,
Dan

#13

i have the same problem with win xp. Actually the problem didnt start up untill I upgraded to win xp. soooo maybe its the os??? if anyone has any answers please e-mail me at sogosuru@hotmail.com

#14

I have a similar problem with running Half-Life in openGL mode.

I have a Geforce2 Mx200. I have installed latest detonator release, and installed directX 8.1

When halflife starts it says my graphics card does not support openGL. I also have the same problem with other 3d APps which use OpenGL acceleration.

any ideas?

#15

I have the same problem with Windows XP, ATI Mobility 128 and Return to Wolfenstein.
It seems the Microsoft video driver for the ATI Mobility 128 card does not support OpenGL. IBM, the laptop manufacturer, does not have any driver for XP that supports OpenGL either. Any ideas?

#16

I have the same problem with Windows 98, a TNT2 64, with Quake 3, Half-Life in openGL mode and Soldier Of Fortune.
I have tested new drivers but it doesn’ work, now I’ll try with GLSetup.

please find something!!!

#17

I have tried running in normal AND safe mode but this message keeps popping up.

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\Program Files\Accessories\HyperTerminal\rtcw\main\sp_pak2.pk3 (232 files)
C:\Program Files\Accessories\HyperTerminal\rtcw\main\sp_pak1.pk3 (1342 files)
C:\Program Files\Accessories\HyperTerminal\rtcw\main\pak0.pk3 (4775 files)
C:\Program Files\Accessories\HyperTerminal\rtcw/main


6349 files in pk3 files
execing default.cfg
couldn’t exec language.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
…detecting CPU, found Intel Pentium III
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----

----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 32
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 8 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 32, 24, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

#18

this is beginning to look like a big problem!!! i get the same error when running quake3, unreal GOTY, return to castle wolf, on XP PRO with 32mb Geforce2mx Pentium III (i815ep chipset) has anyone also got problems using glsetup in xp??? have all uptodate correct drivers anyone got a fix yet?

#19

check this out http://www.uq.net.au/~zzmbisho/how_to_fix-OpenGL-Subsystem.html

didnt work for me, probably coz i’m running xp, should work for most tho me thinks!

#20

Hi,

I had the same problem in XP with a Nvidia RIVA TNT2 Model 64 (driver version 2.3.1.1).
However I also have a second monitor on a S3 Virge PCI card. When I disabled the second monitor in Display Properties, Wolfenstein worked.

Hope this helps,

Rump