Compiling example from Kilgard

I’m trying to work through the first chapter of Kilgard’s OpenGL for X book and I’m having problems getting the glxsimple example on page 31 to compile. The command I’m using (from the book) is:

gcc -o glxsimple glxsimple.c -lGL -lXext -lX11

and the error is:

/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status

I saw this somewhere else on the web, and that page suggested the same command sans “-lXext”, which I tried, but received the same error with “-lX11”. I’m running Debian unstable and I’ve got the xlibs-dev package installed. I’m sure I’m missing something obvious, but I haven’t done much with this stuff so I’m going crazy trying to figure out what. Any suggestions? (RTFM is fine with me, just tell me which one…)

just add -L/usr/X11/lib or whereever your
X11-libraries lie

Duh. Damn, I knew it was going to be something stupid like that. Thanks!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.