Can't load OpenGL sub-system? (ie: XP and C-S, MOH, Q3, etc.)

Hi there,
Ive been thougth that problem too
Ive also seen lots of solutions.
For non w2k or wxp users there is a solution
Start - Run - win.ini
Look for:
DVA=0 <- just delete this line

  • That problem exist in nvidia cars, the kyro, 3dfx etc

I know that issue is related with a file - opengl32.dll that is in c:\windows\system32\ (xp users)
The original file is +/- 320 kb long, the one i have at the moment is 670k. U can have the opengl32.dll in the game root dir (where the .exe is), so when u run the game it looks there and if theres none it will use the one that is in system32 dir.

  • Another solution i saw was:
    Going to c:\windows\appatch and copy acxtrnal.dll to the root of the game ex: c:\games\moh\ and rename this file to opengl32.dll it worked with a tnt2 (ive tried it myself)
  • Other ones are:
    There is a bug in windows xp if u are using 60 hz that can be the reason too, change it to another frequency.
    -In windows xp u can´t run glsetup cause it should be already updated so its said that u just have to download the latest drivers for your card.
    -U can´t either install directx cause windows xp its supposely already updated.
  • If u have a Via chipset motherboard u may need to reinstall the via drivers with turbo agp mode off;
  • U may need to set agp to 1x or 2x in bios menu too.
  • Also check if 3D hardware acceleration is turned all the way up:
    For Windows XP and 2000:
  1. Click on the Start button > Settings > Control Panel.
  2. Double-click the Display icon.
  3. Click the Settings tab.
  4. Click the Advanced button.
  5. Click the Troubleshoot tab.
  6. Make sure the acceleration slider is set to Full.
  • Try setting your desktop to 640*480 and 16 bit color.

I have windows xp a kyro 2 and it works for me (wolfenstein, Sof, half-life, quake, quake 3, jedi knight 2 and medal of honor); dont remember what i did in the past to make it work, but im glad it works.
Ive tried my card in another xp system and didnt work, copied the opengl32.dll to it and still didnt work, so im really missing something here.

All of this solutions made at least someone happy as ive seen in other forums, so try them all.
I would like to know if someone could explain all this stuff:
i know microsoft doesnt like opengl so incompatibility between directx and opengl seems to be the main problem.
Nvidia has new drivers that should solve the problem, but as for others the problem persists.
P.S. For Medal of honor u may also need to delete the 3dfxvgl.dll cause the game try to use it firstly (and its for voodoo cards)
Tell us what´s your card if that helped in some way
Cheers, P4ulo

Just thought I’d bump this up to here cuz I saw so many people with the same lame ass XP prob that I had. Took me three weeks till I found this! Any ways I tried EVERYTHING before any of these methods and now I’m playing counter-strike again!!! YES!!! Anyways I hope this helps…