Cant get animations out of blender

#1

Hi I’m using the latest build of blender 2.8 and also the latest build of the gltf exporter from github. No matter what I do I cant get any of the animations to export.

Initially I thought it was because the animations where driven by graph editor modifiers, so I baked all actions into keyframes, but the animation still isnt exporting…at least it’s not showing up in windows explorer or the 3d viewer app that comes with windows.

I tried importing the .glb file back into blender, but i’m just getting this error:

any clues as to what is going wrong?

#2

Hard to know exactly what’s going on without seeing your .blend file. But I can say that recent builds of the glTF exporter have been fairly unstable for me when it comes to animation.
There are currently multiple open issues related to both animation and shape keys (morph targets). For example, I have a .blend file with an animated character (with an armature) that has many animations stored as NLA tracks. It exported just fine until more recently where bringing the exported glTF (or .glb) into various viewers gives me errors about it missing skinning information.
My advice, other than reporting the bugs you’re finding, is to wait until some of the major github issues have been fixed and try again. Alternatively, if you have the time and patience, you could try to roll back to an earlier version of the exporter.

#3

Thanks, I tried rolling back to 2.79 and using the 2.0 version of the exporter. Animations are now working, but non of the materials are :frowning: Looks like i’m going to have to set all the materials up again with the node group bundled with the khronos files…doh.

#4

well actually, I say animations are working now…but strangely the animations only seem to work if I import the glb into blender. Importing into houdini results in geometry with no animation, and the same happens in the windows 10 3d viewer.

#5

animations were being exported, just that the viewers I was using dont support animation it would seem.