Cannot Link glut w/RedHat 9 (Shrike)

I installed the 3.7-8 distribution of glut just as I had with RedHat 8 …

rpm -Uvh glut-3.7-8.i386.rpm
rpm -Uvh glut-devel-3.7-8.i386.rpm

I can’t get even the simplest redbook example to link …

g++ -o ./gtest cube.o -L/usr/X11R6/lib -L/usr/X11R6/lib -lcap -lpthread -lglut -lGLU -lGL -lXmu -lXext -lX11 -lm

/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXBindChannelToWindowSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to XGetExtensionVersion’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XFreeDeviceList' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to XQueryDeviceState’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XListInputDevices' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to glXQueryChannelDeltasSGIX’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXChannelRectSyncSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to glXChannelRectSGIX’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XFreeDeviceState' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to XOpenDevice’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXQueryChannelRectSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference to XSelectExtensionEvent’
collect2: ld returned 1 exit status
make: *** [gtest] Error 1

Any ideas why?

BTW … I installed nVidia driver 4363 also

Thanks!
Paul

[This message has been edited by pleopard (edited 06-23-2003).]

There are a couple posts about this linking problem already, just look through some of the threads in this forum or use the search feature.

I used the glut 3.7-4 which I was using under Redhat 8.0, and forced installed it on Redhat 9.0

I have to RPM’s just email me and mabye can send them to you.

Also check out the other post on this topic already posted on here in this forum.

g++ -o ./gtest cube.o -L/usr/X11R6/lib -L/usr/X11R6/lib -lcap -lpthread -lglut -lGLU -lGL -lXmu -lXext -lX11 -lm

/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXBindChannelToWindowSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toXGetExtensionVersion’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XFreeDeviceList' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toXQueryDeviceState’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XListInputDevices' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toglXQueryChannelDeltasSGIX’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXChannelRectSyncSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toglXChannelRectSGIX’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to XFreeDeviceState' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toXOpenDevice’
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/…/…/…/libglut.so: undefined reference to glXQueryChannelRectSGIX' /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined reference toXSelectExtensionEvent’
collect2: ld returned 1 exit status
make: *** [gtest] Error 1

Any ideas why?

BTW … I installed nVidia driver 4363 also

Thanks!
Paul

[This message has been edited by pleopard (edited 06-23-2003).][/b]<HR></BLOCKQUOTE>

[This message has been edited by nexusone (edited 06-23-2003).]

Thanks but I found that other thread and succeeded in getting 3.7-8 installed per that other website … https://sourceforge.net/forum/forum.php?thread_id=879028&forum_id=76063

By: jahshaka ( jah shaka )
RE: compiling on redhat 9 ftgl/glut fixes
2003-06-05 01:06
Ok theres a great and easy workaround for this! Basically you need to swap the glut libraries that come with redhat 9 for the ones that come with redhat 8

this is a very simple procedure,

  1. download the files glut-3.7-8.i386.rpm and glut-devel-3.7-8.i386.rpm from redhats website (or any mirror). I got them here:
    [http://www.redhat.com/apps/download/results.html?search%3Aquery_cb=glut&search%3Asource=rpm&search%3Afields=name&search%3Afields=summary&search%3Afields=description&search%3A option](http://www.redhat.com/apps/download/results.html?search%3Aquery_cb=glut&search%3Asource=rpm&search%3Afields=name&search%3Afields=summary&search%3Afields=description&search%3Ao ption) s=match_partial&search%3Afield%3Aarch=i386%2Ci586%2Ci686%2Cnoarch&search%3Ago=Search

  2. you need to force install them on your system:
    rpm -i --force glut-3.7-8.i386.rpm
    rpm -i --force glut-devel-3.7-8.i386.rpm

  3. erase the old libraries (devel first)
    rpm --erase glut-devel-3.7-12
    rpm --erase glut-3.7-12

  4. repeat step 2 to freshen up the system

  5. type ldconfig to refresh the system libraries

Thats it, works perfectly and also fixes the FTGL problems!

Actually, when I tried to remove the old installation it failed, saying it wasnt installed so I ignored that step and it worked fine.

Thanks again!
Paul

[This message has been edited by pleopard (edited 06-23-2003).]

actually you just need to link it with libXi.so (-lXi) and you’ll be fine…

I too am new to openGL (and programming in general). I cannot seem to link the GLUT libraries (using redhat 9). I know that it is installed.
[dwayne@magus slices]$ make
gcc -lm -lGL -lGLU -lglut -lXmu -lXext -lX11 -o slices slices.o integral.o expint.o fluence.o
/usr/bin/ld: cannot find -lglut
collect2: ld returned 1 exit status
make: *** [slices] Error 1

It is probably something small and silly. Any input or advice would be greatly appreciated.

The library is most likely not in your LIB PATH. Not sure which environment variable RedHat uses. You can also explicitly link to the path using -l/…/lib/glut or wherever it is located.

Where does RedHat store GLUT?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.