Blending causes unexpected effect

Hi all,
I’m trying to enable blending to make sphere transparent.
But when I enable it, the effect below occurred.

The dividing line appears even if I use lighting. (Currently I just use glColor and disabled lighting.)
Does anyone know the reason? Thanks.

Here are some related code:
One of the spheres which rotating around center:

	glColor4f(1.0, 1.0, 0.0, 0.6);
	glRotatef(angle, 0, 1, 0);
	glTranslatef(0.0, 0.0, 1.0);
	glScalef(0.3, 0.01, 0.3);

	GLUquadricObj *qobjSphere;
	qobjSphere = gluNewQuadric();
	gluQuadricDrawStyle(qobjSphere, GLU_FILL);
	gluQuadricNormals(qobjSphere, GLU_SMOOTH);
	gluSphere(qobjSphere, 1, 100, 100);

Enable blending:


This is the effect of two gluDisk get intersected. I think they got the same problem.
I tried to enable and disable lighting, depth buffer and culling, but nothing changed.

Has anyone met this kind of problem before?

Search for z-fighting.
You can aleviate it a bit by setting glDepthFunc(GL_LEQUAL).