ATI mobility 5650 compatibility with GLSL 1.2

Hey all, long shot really.

It would appear my graphics card (ati mobility 5650) does not like GLSL 1.2.

Using MSVS2010, never had any problems until trying to use shading languages. Including GLSL stuff causes program to have a mardy and not even enter main (just execute and exit without even entering main).

Tried running some AAA games that utilise shading (such as eve) to see if either it is MSVS or my inadequacies, but these games look worse than my first attempt at pong.

Any ideas if this is fixable, I have ensured all my drivers are up to date (obviously). Have had course mates and lecturers alike try and solve for me but all have come to the same conclusion (outtake of breath and a shrug).

Is this a known issue, have heard of others having same problem but is fixed with simple driver update. No such luck with mine however. If you need more/specific info let me know, any help with this will be great.

Cheers in advance.


It can’t enter main in your C code? Sounds like you have a Windows problem rather than GLSL version 1.2.


Aye, would agree normally, however:

Tried using both glut/glew and SDL, same issue.

All my other programs have no issue entering main (including using opengl without shaders)

As soon as you remove GLSL calls from program, main will run again.

I tried using the tool from that link (gpu-caps) , but both zip and win32 downloads crash on execution (after download). Whether this is related to my problem or not I dont know.

This really is baffling quite a few of us now as the laptop is not too old a model (dell studio 1749) nor too old a graphics card.

Any other suggestions V-Man, I really do appreciate the input.

Are you calling them before main? Such as in the constructor of some global object?

@Alfonse: No, not at all. The simple program I am using was used as a base example for all the students in my class, and works fine on all other machines in the labs, just not on my laptop. Have ensured that properties are set correctly and that any included files/libs are in the right place along with the simple shaders (just altering colour intensity of a square for now, not taxing stuff really).

@V-Man quick update, have managed to get the GPU-CAPS working and run some of the example vids with no issues as yet, is there something specific I should be looking for to prove the system should work?

I am fairly novice at graphics stuff so apolagies if this should be simple, programming is a (relatively) new direction in life for me, so not quite as good at the jargon as some

Actually, I think I may have had some success. I re-installed my graphics drivers from scratch, and now shading seems to be working just fine (something I had tried previously and didnt seem to help).

(also altered a few other things but am sure this was the kingmaker).

Thank you for your responses, 2 months of trying to fix this with armies of helpful souls and it seems to autocorrect.

Again, thanks a bunch

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.